Xv is tearing in 331.13

Xv video is tearing with 331.13 drivers. Everything was fine in previous versions (including 325.15).

Note: it’s only Xv that is tearing. GL is fine.

Have you tried the ForceCompositionPipeline and/or ForceFullCompositionPipeline MetaMode attributes? See http://http.download.nvidia.com/XFree86/Linux-x86/325.15/README/configtwinview.html for details. For some users issue resolved https://devtalk.nvidia.com/default/topic/543305/linux/-fixed-screen-video-tearing-gtx-6xx-7xx-titan-in-almost-all-applications-including-desktop-itself/7/

Please provide below information :

  • Reproduction steps and nvidia bug report
  • Desktop Environment you are using like KDE, GNOME, Unity etc… ?
  • Window Manager you are using Compiz, gnome-shell, Kwin, Unity etc… ?
  • Using any display manager like gdm, kdm etc… ?
  • Is desktop effects or composite on?
  • Video format ?
  • Display and video resolution ?
  • which video player you are using ?
  • Did you tried sync to vblank option in nvidia-settings ?

Doesn’t ForceCompositionPipeline and ForceFullCompositionPipeline lead to performance loss?
I don’t think this is an acceptable workaround…

I have compositing disabled. (“Desktop effects” is completely disabled in KDE’s system settings.)

Reproduction steps: Play any video in mplayer2 using Xv renderer (option “-vo xv”).

Desktop Environment: KDE 4.11.2

Window manager: KWin

Display manager: KDM

Compositing: Desktop effects are disabled.

Video format: All formats.

Desktop resolution: 1920x1080.

Video resolution: All resolutions (from 480p to 1080p).

Video player: mplayer2 (tried 2.0_p20130428 and latest Git master.)

Did you tried sync to vblank option in nvidia-settings: Yes. It only affects OpenGL applications. Not Xv.

I’m attaching the output of “sudo nvidia-bug-report.sh”.

nvidia-bug-report.log.gz (84.4 KB)

Xv is not guaranteed to be tearing free. If it works - it’s by pure luck.

Window manager side compositors have nothing to do with the question sandipt made you.
Using that metamode attributes probably will eliminate tearing for you, but will (probably) lead to a
performance hit, see:
https://devtalk.nvidia.com/default/topic/602831/linux/unrecognized-flatpanelproperties-property-quot-scaling-quot-/post/3941157/#3941157

Why not? It was always vsynced in the past. Always. This is the first driver ever that breaks that.

And how can Xv be vsynced “by luck” to begin with? Either it is or isn’t.

This is what Aaron said:
https://devtalk.nvidia.com/default/topic/602831/unrecognized-flatpanelproperties-property-quot-scaling-quot-/?offset=12#3941192

It seems that’s for Kepler. I’m on Fermi.

His point does not depends on architecture:

Yes, best-effort means luck.

Oh, i just saw your xorg.log, you’re using triple buffering, that’s another option i’d turn off because it is known to cause tearing.
you don’t need it at all if kde is running with effects disabled, and even with effects enabled there are valid alternatives.

Right now this isn’t a problem since I downgraded back to the previous driver. But it’s worrying to see that the NVidia driver isn’t really dealing well with VSync on Xv or VDPAU and that a compromise is required to get it to work. Using OpenGL instead of Xv isn’t a solution either, since I want to keep GL VSync disabled.

This is a serious problem.

First i’d try to disable triple buffering vsync disabled make it completely useless.
(if kwin in console complains about it when you enable effects and disable vsync because your visual isn’t triple buffered, then you can export __GL_YIELD=USLEEP to meke it happy again.)

I have tearing in xv and on vdpau with triple buffering enabled, regardless of the driver version.

As for GL not being a solution, keep in mind that you can override default GL vsync on a per application basis by setting by setting __GL_SYNC_TO_VBLANK
http://us.download.nvidia.com/XFree86/Linux-x86/180.22/README/chapter-11.html

I have VSync disabled in NVidia’s control panel. I still enable it the settings of games. KWin doesn’t work well when VSync is forced on in NVidia’s control panel (it results in some stuttering in the animations.)

My actual setup isn’t what I described in my reply to sandipt. That was only the easiest configuration to reproduce the problem, taking compositing out of the equation as the source of the problem. I do use desktop effects. And triple buffering is very helpful when running games and having VSync on for them.

Thanks for the tip about the environment variable to force VSync on. Might come in handy. Though another reason I use Xv is that according to various information I read on the net, Xv and VDPAU have very good scaling filters.

But again, I was just reporting the problem to the NVidia devs. I’m not interested in a solution for it at the moment, as I will be sticking to the current stable driver version for quite a while if the problem isn’t fixed later on. Paired with the extremely serious bugs in NVidia’s Windows drivers in the last 7 months (I’m dual booting), I might buy another graphics card anyway later down the line, if the current drivers are too outdated to support newer software and/or games.

RealNC, We will see if we can repro and investigate this issue. Filed Bug 1393320 to track it.

Hi RealNC, We are trying to repro this issue with Ubuntu 13.10 x86_64 but we are seeing tearing for both drivers previous and latest. If possible could you please share video clip and recording of tearing video issue ?

Hello,

My problem is a bit different but I add my contribution because of tearing while playing videos (vdpau)
Card : GTX 680
ArchLinux 64
Drivers : tried from 304.116 to the latest one without luck
Xfce + Compiz

I have annoying tearing in Xfce. Vsync enabled in nvidia-settings. To be sure it was not a compiz issue, I tried compton : same tearing.

/!\ The tearing is located at the top of the screen !

It seems to be cyclic (or it looks like). Just after the login, I open xfce4-terminal and then I can move it eternally without tearing at all. That’s when I stop moving it, and try again that the huge tearing appears.

I’ve tried for 3 days all tips found my friend Google, none worked.

Cyclic, because sometimes I can play my tearing test video entirely OK, sometimes the tearing occurs the first 20/30s then disappears, sometimes it plays fine at the biginning then fails at the end… and so on…

The only workaournf I’ve found : Dell U2410 1920x1080 50Hz (instaed of 1920x1200 60Hz) but it’s a bit ugly and NOT a solution.

Hope this helps

I’ve now got a GTX 780. The problem is still there, and in addition, I see corruption on the tearing line. The problem is there with 319.82 and 331.38.

VDPAU does not have this problem; it’s tear-free. Only Xv is affected. I still want to use Xv because VDPAU crashes mplayer when switching between fullscreen and windowed.

Is there a reason you don’t want to use mplayer2?

I was using it too. It behaves the same way. Crashes with VDPAU when switching from fullscreen.

No such problem with mpv with 331.38.