MANJARO LINUX 15.12 352.63 Fermi gtx580 tearing in OpenGL applications

I have to say I solved KDE 5.5 and Plasma shell with kwin tearing have nice VLC playing on youtube.com videos on latest WHQL LTS branch, but with these fix described on these great guys site:

https://wiki.manjaro.org/index.php?title=Simple_fix_for_screen_tearing_-_nVidia

the most saddest thing is that fix has nothing to do with OpenGL applications like sauerbraten or teeworlds ;D

and I have no such problems under Ubuntu Linux cause it’s using compiz as composting manager and lightdm as windows manager I thought it is a root of why Ubuntu running flawlessly with any nvidia binary drivers.

but the opensuse and manjaro linux kde redaction are affected cause of using kwin ;( for that purposes.

fix me if I wrong in stating something.

please guys can you give a tip what I can do? I can’t install unity here on suse or manjaro cause it breaks dependencies, but I have to try gnome or other DE with something different in terms of composing and window manager? I already installed gnome, mate, cinnamon, deepin, i3 and few of them from repositories without conflicting dep’s

I have only one gtx580 and one display. When I disable VSYNC in game (sauerbraten, teeworlds) I have stable +150-200 fps and no screen tearing at all.

And I really wont to switch from KDE to other ugly desktop environment, I really like and want to stick myself to KDE ^_^

Thanks NV dev team.

So the meta mode pipelines just doesn’t work on gtx580? only higher 600 series? for now I just switched to my old Ubuntu installation which has compiz and lightdm. Nor suse nor manjaro on kde redactions does not work properly with VSYNC OpenGL 3D applications. It causes 59-60 fps.

Once I am running away from last Windows (10&others) experiences with CTD I just facing similar problems with NVIDIA drivers on Linux but with VSYNC tearing and fps drops when it happens to 59 then goes 60 and these is going to be happen in cycles in any 3D application but with Xorg+kwin+kde stack.

I am really hope that these sometime can be fixed in near future. Thank you for great work.

One question, do you use triple buffering?

Option “TripleBuffer” “boolean”
Enable or disable the use of triple buffering. If this option is enabled, OpenGL windows that sync to vblank and are double-buffered will be given a third buffer. This decreases the time an application stalls while waiting for vblank events, but increases latency slightly (delay between user input and displayed result).

Can I ask you how to disable it? I just used on MANJARO Linux these guide https://wiki.manjaro.org/index.php?title=Simple_fix_for_screen_tearing_-_nVidia

I am do not familiar with how to disable triple buffer widely and I suggest my current nvidia xconfig is placed like these /etc/X11/xorg.conf.d/95-mhwd.conf last time I saved to these way and moved all old to down folder called “backup” with .bak .old extensions.

If you can point me to how to disable triple buffering system widely on nvidia binary driver config I will gladly try to apply these fix, or I just search lately on internet for myself cause I just now sitting on Ubuntu 16.04 december 28 xenial snapshot. It same like 15.10 with minor changes but actually it is 100% stable even if it Alpha just for your information.

Thank you for the answer. I am not sure if it one. Never mess myself with nvidia-xconfig on suse or manjaro I see NVIDIA devs is pretty much fixing GDM3 gnome bugs for Fedora 23 and some of regressions related to their last statement “technologies” but sadly they have nothing but zero connectivity and fixes for Kwin or KDM or what is related to these problem in KDE 5.5.

Anyway I try to disable these later on if I manage to try enter MANJARO/SUSE world on these weekend and NVIDIA should fix driver for not only Red Hat / Fedora based distributions. Hopefully Wayland is coming soon in 2016. But these not fixes all “blob” kind of problems of binary driver.

I do not think either that AMD has deal a greater job “open sourcing” their blob half-a-way but at least NVIDIA blob working here in Ubuntu fine on my engtx580 DCII 1536Mb cause I have writing few posts under these nick name on Windows drivers forums section and I have terrible experience with NVIDIA drivers in all windows from 7 to 10 and all builds.

These situation must be fixed some day or I just build full AMD PC or full Intel IGP and just sitting on integrated Intel GPU’s for future plans. I do not think that situation on AMD was really got to be improving since 2016 and I don’t believe them.

Afaik triple buffering should be on, if you want to use vsync while gaming. It should help if you encounter any screen tearing caused by default vsync with double buffering. You should add it(Option “TripleBuffer” “True”), in your xorg.conf nvidia’s device section(should be on /etc/X11/xorg.conf, /etc/X11/xorg.conf.d/20-nvidia.conf or similar).

If you don’t want to use triple buffering you can try use export __GL_YIELD=“USLEEP” as kde environmental variable. See https://community.kde.org/KWin/Environment_Variables#Set_variables_at_session_start how to do it. But you should do this only if you don’t want to use triple buffering. You can’t have both settings on at the same time.

Thanks I try to enable it. OK it seems I understand how to add env variables to kde4/5 and also figure out where and how to tweak settings related to tearing in nvidia xconfig. Perhaps tomorrow or these weekend I might try to tune these things.

Another thanks for the great advices. Now I have imagine how to deal with it.

Sadly I just readen that xorg.conf is deprecated according to these topic https://forum.kde.org/viewtopic.php?f=111&t=130942

xorg.conf is deprecated, avoid using it.
Instead add a configlet as posted and have the server incorporate it during the auto-setup-

I really wont try to mess more with KDE but it nice and I have to try to deal with that problem for sure.