z97 MB, cuda, nvidia driver, ubuntu 14.04 = black screen

I really need your help on this. I have been trouble shooting my computer issues for past 2 months now. what happened was I have a sandy bridge/z77 combo that i used over past 3 years that worked fine for CUDA, etc. and i decided to upgrade to new z97 and haswell combo during Xmas time. i also installed ubuntu 14.04 and got gtx 970. i’m a researcher and do not play games i need cuda and nothing else running on ubuntu. however, i had all sorts of problems with these boards. i can’t pin point where things are going wrong. is the new h/w? ubuntu not compatible? cuda driver not working? i think it really boils down to nvidia driver. when i install ubuntu via intel iGPU, everythign is working. so i plug in gtx 680, boot, it still comes up but driver not the latest. so i installed cuda 6.5 and lately 7.0rc and this is when things go to hell. upon passing bios screen it seems like grub or something is doing some sort of a splash screen but it goes blank. i have tried different cards, 680, 780, 970 and none of them. work.

i want all 3 of these in one MB so that i can profile all 3 of them. so i got a MB that can do 4 PCIE such as asus z97-ws, gigabyte gaming gt, and lastely asrock oc formula. i eneded up retruning all of them except asrock oc formula. this was working perfectly fine for past 5 days and one day i’ll get this black/blank screen again. so i unplugged all GTXs and boot from intel and seems to be fine. so i uninstalled nvidida driver and reinstall to new driver 346.75? i think then plug in 1 GTX and it comes up fine. but i check cuda and it says cuda is not found. i must have deleted something when i purged nvidia. so i in stall cuda 7.0rc and it says it still doens’t work.

i tried so many variations now. the problem is there when i do 7.0rc.deb install which contains the drive.r when i install driver separately and cuda separtely cuda doens’t work. so nothing works. what am i doing wrong? do you have these issues. should i return all these MB and get a more mainstream MB with 2 PCIE slots such as asus z97-a, extreme4, etc.?

do you use z97/hasweell combo that works with ubuntu 14.04 and latest cuda? i really really can’t spend any more time on this i have paper deadlines coming up and this is causing major crisis here. i can use any help right now. i just want something that works and stable. i’m lost at this point… thanks a lot

Here’s what I would suggest.

  1. Do a clean load of Ubuntu 14.04 64-bit on the system with just the intel graphics. Leave the NVIDIA GPUs unplugged and out of the system. Get everything else working the way you want it. (You seemed to indicate this was possible. If you can’t complete this step, your issues have nothing to do with CUDA or NVIDIA GPUs.)

  2. remove any traces of the nouveau driver. There are various ways to accomplish this. I would suggest the following, as root:

echo -e "blacklist nouveau\noptions nouveau modeset=0"  > /etc/modprobe.d/disable-nouveau.conf
update-initramfs -u
  1. Find the latest NVIDIA GPU linux driver for your GTX 970. It will also work with all the other GPUs you mention (680, 780). At the moment, I would suggest 346.47:


Download this .run file installer for the driver.

  1. Install all 3 NVIDIA GPUs into your system. (power down, of course)

  2. Using the .run file installer from step 3 (do not use apt or package manager methods), install the NVIDIA driver BUT select “no” when prompted to update the xorg.conf file/information. You do not want X to be operating on these GPUs.

  3. Reboot the system. Hopefully, nothing should have changed. Things should still be working normally and your display output should still be coming from the intel graphics. If this is not the case, you will need to sort this out. It means that your motherboard has auto-switched primary graphics from the onboard intel graphics to one of the add-in cards. Some motherboards do this, when a VGA card is plugged in. There may be BIOS settings to control this, to force the primary graphics to the on-board intel graphics. Try this first. If not, you can resort to modification of the xorg.conf or other display control mechanism to identify the specific PCI address of the onboard graphics as part of the “display” entry. This should rectify the problem also. This customer help note may be useful:


  1. If you’ve gotten past step 6 with the display working from the intel onboard graphics, you can now load CUDA. Download the appropriate runfile installer (do not use apt or package manager methods) from either the CUDA 6.5 or CUDA 7 RC download page (either will work). You should select the runfile installer for Ubuntu 14.04 64-bit. You can get the CUDA 6.5 package here:


  1. Follow the runfile install method instructions from here:


BUT select no when prompted to install the bundled GPU driver in the CUDA installer package. You want to leave your previous driver intact.

I’ve got a machine with Intel HD4600, Nvidia GTX 980 and AMD R9 270X (doing cross-platform OpenCL). It has a 4K display connected through DP to HD4600 (the only way I could get video output for UEFI setup). Here is what worked for me to get the GTX 980 running on Ubuntu 14.04 x64 with OpenCL and CUDA:

Only Ubuntu 14.04 worked – not 12.04, or 14.10. Upgrading a working 14.04 to 14.10 gave a black screen upon reboot.

Installed all updates for a fresh 14.04. Reboot.
Added ppa:xorg-edgers/ppa as repository, added the +sources option, installed all updates. Reboot.
Installed nvidia-346-dev through apt-get, this got me the recent 346.47. Reboot.
Made sure everything looked fine in nvidia-settings.
Downloaded the .run file for the 7.0-RC CUDA SDK.
Extracted the .run file by running it with the -extract option, got 3 separate .runs with SDK, samples and driver.
Installed SDK and samples. The driver is <346.47 (.29 I think), so it didn’t work for me.
Both the CUDA samples and my OpenCL code are running fine!

I’m a complete Linux newbie, so there is likely a smarter solution to this problem – but it seems to work.

“Added ppa:xorg-edgers/ppa as repository, added the +sources option, installed all updates.”

what does that mean? My 14.10 install fails with black screen like you said, so I am willing to try 14.04, but I’m even more of a linux noob, and don’t remember any step installing 14.10 where it offers me the option to update a repository. Where/when do you do this?

I got Ubuntu 14.10 working with Cuda 7, so don’t need the explanation of ppa. Bottom line for me was to create symbolic links in the /usr/lib directory so that things like libGL.so (which didn’t exist) point to libGL.so.1 (which did exist). There were 4 or 5 of these I had to create, which I discovered by reading the make file I was trying to build and also by reading the Nvidia getting started file in detail, confirming the presence (and location) of every .so file they mention. I also had to install freeglut3 since Xlib.so was missing entirely. It was tedious, but now I have the mandelbrot demo running, so I’m calling it good.