Two vga (intel hd 4600 and nvidia geforce 940m), how to install cuda ???

I have msi cx61 2QF

  • Intel core i7
  • 4 GB RAM
  • Display Adapters
    – Intel® HD Graphics 4600
    – NVIDIA GeForce 940M

When I tried to install CUDA 7.0, it says I don’t have a compatible device.

I tried
- setting the preferred graphics card as nvidia
- selecting from right click option
but not working

When I tried to disable intel hd monitor stops working.
There are no options to disable nvidia through bios.

Please help me .
Thank you in advance.

THe GeForce 940m is newer than the display driver that is contained in CUDA 7. You can use CUDA 7 with your GeForce 940m. Install CUDA 7 but select custom install and deselect the option to install the driver. This will retain your existing display driver for GeForce 940m which will work fine with the CUDA 7 toolkit.

I tried in both windows and ubuntu. I installed cuda without the driver. But, it’s not working. When I try to install nvidia driver (downloaded from official site) in ubuntu, I cannot login, the login page keep on prompting.

You certainly do need a driver. I had assumed you had a laptop that had shipped with windows on it. In that case, a compatible driver was already loaded on your GPU. Then you can load CUDA 7 and it will make use of the existing driver.

If you’ve wiped that out and just loaded windows, for example, with “without the driver”, then the GPU is not usable that way.

Using Ubuntu on an Optimus laptop is considerably more difficult. I would suggest trying to get the windows things running first.

Load windows.
Load the latest GPU driver for your 940m from www.nvidia.com
Then load CUDA 7 while deselecting the option to install the driver.

And if you give a statement like “But, it’s not working.” that is almost useless for trying to help you. You’ll need to be more specific about the steps you followed, and what exactly you observed that looked wrong.

Thank you very much, it’s finally working. I followed exactly as you said.

I have windows 7 x64 and visual studio 2010. I have already installed the driver for my nvidia hardware. I am sorry for not giving more details (as I am little new to forums, this is my second question).

What I meant was

  • when I try to install cuda it said " The graphics driver could not find compatible graphics hardware. You may continue installation, but you will not be able to run CUDA application." any how I continued installation dis-selecting nvidia driver from advanced option.
  • and then when I try to create a new project under cuda in visual studio to check whether it’s working. it said “fatal error lnk1123”*, I thought this is an error caused by incorrect installation of cuda, but it’s not.

*fatal error lnk1123 : this is an error caused by visual studio.
Go to : project -> Properties (Alt+F7) -> Configuration Properties -> Linker -> General -> Enable Incremental Linking : and change Yes to No, then Apply and OK.

This is the silly mistake I made. I am sharing this with others, so that don’t do the same mistake I did.

Thanks txbob for your time and effort. Actually this I how I got it working

If you can tell me how I can run cuda it ubuntu it would be more helpful.

I tried to install cuda using a .run file.

  • I downloaded cuda and convertd it to a executable
  • I logged in to tty1 mode (Ctrl+Alt+F1)
  • Stopped the lightdm
  • I ran the executable cuda as a super user and selected all three to install (including the driver)
    This is how I got cuda working in my desktop computer, but when I try to do the same in my laptop I am facing following problems.
  • it will not log in
  • ubuntu startup page freeses
  • it prompts a low resolution message

Therefore I tried to install driver (downloaded from the official site) only. I face the same problem as above.

Please help me .

Hello everyone, I tried to run cuda on ubuntu as saai, and I have experienced same difficulties as described #6. I tried everything as I can, no positive conclusion. Have ubuntu on Lenovo Yoga 500 with Geforce GTX 940M (turned of Intel card via Nvida-settings).
Is there anything new ?

Hi Small792, I had so many problems while I was installing CUDA in Ubuntu, now I don’t. All what I did is install ubuntu 15.04 and cuda 7.0. deb (local) file and I installed by

sudo dpkg -i cuda-repo-ubuntu1504-7-5-local_7.5-18_amd64.deb
sudo apt-get update
`sudo apt-get install cuda

this works fine for me. What I found is, if your device is new you have to install new drivers, or simply install new CUDA version.
Hope this helps you.