Installation problems on new MSI GS70 w/ 970M GPU

Hi all!

I received my new laptop today, which as mentioned comes with the latest iteration of the GTX mobile GPU. I’ve installed the latest drivers, which currently are 344.24, and attempted to download two separate CUDA SDK versions from the website. I downloaded 6.5 for the mobile platform, but also since a message came up regarding the 9xx series needing a different driver i downloaded that one too (only desktop was available though).

The mobile driver, when attempting to install gives an error message that “no compatible hardware could be found”, which is the exact same error that the other installer i downloaded gives. Is the issue that there hasn’t been a notebook SDK download for the 9xx series released just yet, or is there something else i am missing?

Any help you can provide would be appreciated!

I guess this is windows?

Use whatever driver is recommended for you laptop, such as 344.24, and then load the CUDA 6.5 toolkit, but de-select the option to install the driver (that comes with the toolkit). This will leave the 344.24 driver intact. This should be OK with CUDA 6.5.

Thanks for your reply, yes i should have clarified that this is Windows 8.1. The driver is updated on the card, and yes it’s 344.24.

So, i’m trying to install the toolkit and right where it does system detection it says it cannot find compatible hardware, is this normal? I’ve continued the installation and deselected the driver install. I’ll give that a whirl and see if anything has changed!

I’m having the same issue. I got MSI GS60 with Windows 8.1 and NVidia 970m. I downloaded cuda_6.5.14_windows_notebook_64.exe and cuda_6.5.19_windows_general_64.exe. Ran both of them, and got error “no compatible hardware”. Anyone found a solution?

I need this for Cuda development.

You need to load a compatible driver, which you should probably have on your system already (no need to change it or load another driver).

When you run the CUDA installer, de-select the option to install the driver.

Perhaps you should re-read this thread, carefully. Note the last comment from kaizokushinobi.

“I’ve continued the installation and deselected the driver install. I’ll give that a whirl and see if anything has changed!”

I can only assume that since there were no further responses, there were no further issues.

Thank you, txbob, your advise worked! I can continue development of Cuda apps on the laptop now!

Having gone through this with a laptop 980m, I think it is important to add that once you start installing the CUDA installer, it will FIRST complain about the driver, then LATER give you the option of a custom install. At that point you de-select the install driver option, and let it go.

It should work at that point, assuming you have a fairly new driver.

Still this is a problem which Nvidia should fix, as it is confusing for the reasons mentioned in this thread.

Hello Friends, currently I have a laptop MSI GTX970M G-SYNC. I need to install CUDA NVIDIA for use the advantage of this options. Today I intented install but I can’t because the system show an mensaje of error and system no finded.

Please can you help me, what type of CUDA NVIDIA , I should installer.

Thanks a lot for your opinion.

The instructions are contained in this thread.