144Hz screen doe snot feel like even 60Hz after config update

My laptop is ASUS TUF A15 Ryzen 5 4600H with NVIDIA GeForce GTX 1650 Ti graphics. My screen is 144Hz.

Below is the system details. Taken from neofetch command.

OS: Arch Linux x86_64
Host: ASUS TUF Gaming A15 FA506II_FA506II 1.0
Kernel: 5.10.14-arch1-1
Uptime: 1 min
Packages: 1098 (pacman)
Shell: bash 5.1.4
Resolution: 1920x1080
DE: Cinnamon 4.8.6
WM: Mutter (Muffin)
WM Theme: Adapta-Nokto (Adapta-Eta)
Theme: Adapta-Nokto [GTK2/3]
Icons: Pop [GTK2/3]
Terminal: guake nvidia-bug-report.log.gz (414.4 KB)
CPU: AMD Ryzen 5 4600H with Radeon Graphics (12) @ 3.000GHz
GPU: AMD ATI 05:00.0 Renoir
GPU: NVIDIA GeForce GTX 1650 Ti Mobile
Memory: 1487MiB / 7432MiB

I installed nvidia driver and added a config /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf so that I don’t have to prepend prime-run in games command.
Section “OutputClass”
Identifier “Nvidia Prime”
MatchDriver “nvidia-drm”
Driver “nvidia”
Option “AllowEmptyInitialConfiguration”
Option “IgnoreDisplayDevices” “CRT”
Option “PrimaryGPU” “Yes”
ModulePath “/usr/lib/nvidia/xorg”
EndSection

Doing so, I noticed that in nvidia-settings, X server 0 tab was also available besides GPU-0 tab. Also, In gameplays, the FPS displayed in corner was relatively higher(before adding config: 60-80fps, after adding config: 110-150fps (in CSGO)). But still, to my eyes the 144Hz is not like even 60Hz screen. I can feel that laggyness even when moving the mouse cursor. The www.testufo.com also gave 144Hz while it was not even 60Hz to my eyes.

When I remove the above mentioned config, the screen feels like 144Hz as in Windows and I can feel that even when moving the mouse cursor. But I dont get option of X server 0 in nvidia-settings. The main disappointment is I get low fps(60-80) in prime-run compared to Windows(120-150fps).

How can I fix this lagginess in screen even though in software level it shows 144Hz?

You need to enable prime sync by setting the kernel parameter
nvidia-drm.modeset=1
Since you have an AMD/Nvidia combo, you might also have to change
/usr/share/X11/xorg.conf.d/10-amdgpu.conf
to use the ‘amdgpu’ instead of ‘modesetting’ driver.

1 Like

Thank you. Your suggestion worked. Now, it feels like 144Hz. However the gameplay is not smooth as it is in Windows. Is this expected or there could be some tweaks in nvidia configs that I could apply?

Please create a new nvidia-bug-report.log so I now about the current setup.
Which games are you playing (native/proton) and what issues arise (microstutter/low fps)? How do you start them (directly/through steam)?

I play CSGO through steam. It is smooth but when I do fps benchmark on benchmark map, I get 115-125fps on average. In windows, it is 135-145fps. May be it is because of turbo mode provided by asus armoury crate in windows. I have added nvidia bug report. Once again thank you for looking into it.nvidia-bug-report.log.gz (363.7 KB)

cs:go on linux should be on par with playing on windows under the same conditions. From googling, I got the impression that the asus turbo mode basically just sets the windows power manager to “performance” and then throttles up the fans to maximum so the cpu and gpu use boost mode more often/continuously. Don’t know if it will raise clocks as well but I don’t think so.
In the cs:go case at 1920x1080, the game is cpu bound, meaning no gpu tweaks will help. You can install Feral’s gamemode application, this will set the cpu scheduler to performance as well. Of course, you can also install a fan manager to set it to 100% but I don’t know if that’s wanted and might be fiddly/impossible with more than one fan.
In general, you might want to install acpid so the nvidia driver can react to changing to battery.

1 Like

Sorry I didn’t mentioned previously about the tweaks that I have applied on linux. I have already installed gamemode and integrated its command in csgo. Also, I am using a working fork of faustus for my device. I will give acpid a try. Thank you.

There also seems to be a bug with cinnamon:
https://github.com/linuxmint/cinnamon/issues/9803
One effect of that being g-sync not working but this also costs fps without g-sync. Maybe check that setting.

There is no “Allow G-SYNC/G-SYNC Compatible” and “Enable G-SYNC/G-SYNC Compatible Visual indicator” options available in my device’s nvidia-settings. How do I enable them?

You misunderstood. You don’t have gsync but you should check the option to disable the compositor for full-screen windows in the cinnamon settings. That one has a bug right now.

One thing I noticed is the lines are much jagged in linux. Is there any way I could fix this?.
Right one is of linux and left one is windows.

Never mind. I managed to fix this by setting FXAA anti aliasing enabled.