18.10 CE MacOS installation fails

When I try to install the latest 18.10CE package on HighSierra, it fails while “validating”. The message in /var/log/install.log file is:

““nvvpâ€� couldn’t be moved to “libnvvpâ€� because an item with the same name already exists.”

Al

Do you already have the cuda toolkit installed on your machine? I’m not aware of any conflicts on macOS. Any chance you could post the full install log? Are there other conflicts or just nvvp?

/var/log$ cat install.log
2018-11-19 16:25:27-07 MP-2 Installer[2108]: @(#)PROGRAM:Install PROJECT:Install-1000
2018-11-19 16:25:27-07 MP-2 Installer[2108]: @(#)PROGRAM:Installer PROJECT:Installer-920
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Hardware: MacPro5,1 @ 3.33 GHz (x 12), 49152 MB RAM
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Running OS Build: Mac OS X 10.13.6 (17G3025)
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: _CF_USER_TEXT_ENCODING=0x1F5:0x0:0x0
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: TMPDIR=/var/folders/c
/ptc_51lj4nq62xnd74zxtq5h0000gn/T/
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: HOME=/Users/algreynolds
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: SHELL=/bin/bash
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: SSH_AUTH_SOCK=/private/tmp/com.apple.launchd.LvYqMQCje6/Listeners
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: Apple_PubSub_Socket_Render=/private/tmp/com.apple.launchd.vyVSvDGsQ2/Render
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: DISPLAY=/private/tmp/com.apple.launchd.1Q3rau0PWU/org.macosforge.xquartz:0
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: PATH=/usr/bin:/bin:/usr/sbin:/sbin
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: LOGNAME=algreynolds
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: XPC_SERVICE_NAME=com.apple.xpc.launchd.oneshot.0x10000004.Installer
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: COMMAND_MODE=unix2003
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: USER=algreynolds
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Env: XPC_FLAGS=0x0
2018-11-19 16:25:27-07 MP-2 Installer[2108]: PGI 18.10 Installation Log
2018-11-19 16:25:27-07 MP-2 Installer[2108]: Opened from: /Volumes/PGI 18.10/PGI 18.10.pkg
2018-11-19 16:25:28-07 MP-2 Installer[2108]: Product archive /Volumes/PGI 18.10/PGI 18.10.pkg trustLevel=202
2018-11-19 16:25:30-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=18187=0x470b expectedThread=21251=0x5303
2018-11-19 16:25:30-07 MP-2 system_installd[2109]: installd: Starting
2018-11-19 16:25:30-07 MP-2 system_installd[2109]: installd: uid=0, euid=0
2018-11-19 16:25:30-07 MP-2 installd[2111]: installd: Starting
2018-11-19 16:25:30-07 MP-2 installd[2111]: installd: uid=0, euid=0
2018-11-19 16:25:30-07 MP-2 system_installd[2109]: PackageKit: Install sandbox purging reclaimed Zero KB
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17411=0x4403 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=15619=0x3d03 expectedThread=21251=0x5303
2018-11-19 16:25:36-07 MP-2 Installer[2108]: InstallerStatusNotifications plugin loaded
2018-11-19 16:25:40-07 MP-2 Installer[2108]: ================================================================================
2018-11-19 16:25:40-07 MP-2 Installer[2108]: User picked Standard Install
2018-11-19 16:25:40-07 MP-2 Installer[2108]: Choices selected for installation:
2018-11-19 16:25:40-07 MP-2 Installer[2108]: Install: “PGI 18.10”
2018-11-19 16:25:40-07 MP-2 Installer[2108]: Install: “(null)” at path “//opt/pgi”
2018-11-19 16:25:40-07 MP-2 Installer[2108]: PGI 18.10.pkg#PGI18.10.pkg : com.pgroup.PGI18.10.pkg : 18.10
2018-11-19 16:25:40-07 MP-2 Installer[2108]: ================================================================================
2018-11-19 16:25:40-07 MP-2 Installer[2108]: It took 0.00 seconds to summarize the package selections.
2018-11-19 16:25:40-07 MP-2 deleted[403]: diskmanagement: [DMManager(PrivateMethods) clientConforms:error:]: currentThread=17163=0x430b expectedThread=21251=0x5303
2018-11-19 16:25:40-07 MP-2 Installer[2108]: -[IFDInstallController(Private) _buildInstallPlanReturningError:]: location = file://localhost
2018-11-19 16:25:40-07 MP-2 Installer[2108]: -[IFDInstallController(Private) buildInstallPlanReturningError:]: file://localhost/Volumes/PGI%2018.10/PGI%2018.10.pkg#PGI18.10.pkg
2018-11-19 16:25:40-07 MP-2 Installer[2108]: Set authorization level to root for session
2018-11-19 16:25:46-07 MP-2 Installer[2108]: Administrator authorization granted.
2018-11-19 16:25:46-07 MP-2 Installer[2108]: Will use PK session
2018-11-19 16:25:46-07 MP-2 Installer[2108]: Using authorization level of root for IFPKInstallElement
2018-11-19 16:25:46-07 MP-2 Installer[2108]: Starting installation:
2018-11-19 16:25:46-07 MP-2 Installer[2108]: Configuring volume “HighS”
2018-11-19 16:25:46-07 MP-2 Installer[2108]: Preparing disk for local booted install.
2018-11-19 16:25:46-07 MP-2 Installer[2108]: Free space on “HighS”: 82.43 GB (82427715584 bytes).
2018-11-19 16:25:46-07 MP-2 Installer[2108]: Create temporary directory "/var/folders/c
/ptc_51lj4nq62xnd74zxtq5h0000gn/T//Install.21080JsXtq"
2018-11-19 16:25:46-07 MP-2 Installer[2108]: IFPKInstallElement (1 packages)
2018-11-19 16:25:46-07 MP-2 installd[2111]: PackageKit: Adding client PKInstallDaemonClient pid=2108, uid=501 (/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer)
2018-11-19 16:25:46-07 MP-2 Installer[2108]: PackageKit: Enqueuing install with framework-specified quality of service (utility)
2018-11-19 16:25:46-07 MP-2 installd[2111]: PackageKit: ----- Begin install -----
2018-11-19 16:25:46-07 MP-2 installd[2111]: PackageKit: request=PKInstallRequest <1 packages, destination=/>
2018-11-19 16:25:46-07 MP-2 installd[2111]: PackageKit: packages=(
“PKLeopardPackage <id=com.pgroup.pkg.PGI18.10, version=18.10, url=file://localhost/Volumes/PGI%2018.10/PGI%2018.10.pkg#PGI18.10.pkg>”
)
2018-11-19 16:25:47-07 MP-2 installd[2111]: PackageKit: Extracting file://localhost/Volumes/PGI%2018.10/PGI%2018.10.pkg#PGI18.10.pkg (destination=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/4C266DDE-6197-436D-8D17-A3BDE76192E2.activeSandbox/Root/opt/pgi, uid=0)
2018-11-19 16:25:59-07 MP-2 installd[2111]: PackageKit: prevent user idle system sleep
2018-11-19 16:25:59-07 MP-2 installd[2111]: PackageKit: suspending backupd
2018-11-19 16:25:59-07 MP-2 install_monitor[2124]: Temporarily excluding: /Applications, /Library, /System, /bin, /private, /sbin, /usr
2018-11-19 16:25:59-07 MP-2 install_monitor[2124]: Re-included: /Applications, /Library, /System, /bin, /private, /sbin, /usr
2018-11-19 16:25:59-07 MP-2 installd[2111]: PackageKit: releasing backupd
2018-11-19 16:25:59-07 MP-2 installd[2111]: PackageKit: allow user idle system sleep
2018-11-19 16:25:59-07 MP-2 installd[2111]: PackageKit: Install Failed: Error Domain=NSCocoaErrorDomain Code=516 ““nvvp.appâ€� couldn’t be moved to “libnvvpâ€� because an item with the same name already exists.” UserInfo={NSSourceFilePathErrorKey=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/4C266DDE-6197-436D-8D17-A3BDE76192E2.activeSandbox/Root/opt/pgi/osx86-64/2018/cuda/9.2/libnvvp/nvvp.app, NSUserStringVariant=(
Move
), NSDestinationFilePath=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/4C266DDE-6197-436D-8D17-A3BDE76192E2.activeSandbox/Root/opt/pgi/osx86-64/2018/cuda/9.1/libnvvp/nvvp.app, NSFilePath=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/4C266DDE-6197-436D-8D17-A3BDE76192E2.activeSandbox/Root/opt/pgi/osx86-64/2018/cuda/9.2/libnvvp/nvvp.app, NSUnderlyingError=0x7fa44b7009c0 {Error Domain=NSPOSIXErrorDomain Code=17 “File exists”}} {
NSDestinationFilePath = “/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/4C266DDE-6197-436D-8D17-A3BDE76192E2.activeSandbox/Root/opt/pgi/osx86-64/2018/cuda/9.1/libnvvp/nvvp.app”;
NSFilePath = “/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/4C266DDE-6197-436D-8D17-A3BDE76192E2.activeSandbox/Root/opt/pgi/osx86-64/2018/cuda/9.2/libnvvp/nvvp.app”;
NSSourceFilePathErrorKey = “/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/4C266DDE-6197-436D-8D17-A3BDE76192E2.activeSandbox/Root/opt/pgi/osx86-64/2018/cuda/9.2/libnvvp/nvvp.app”;
NSUnderlyingError = “Error Domain=NSPOSIXErrorDomain Code=17 “File exists””;
NSUserStringVariant = (
Move
);
}
2018-11-19 16:25:59-07 MP-2 installd[2111]: PackageKit: Running idle tasks
2018-11-19 16:25:59-07 MP-2 installd[2111]: PackageKit: Removing client PKInstallDaemonClient pid=2108, uid=501 (/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer)
2018-11-19 16:25:59-07 MP-2 Installer[2108]: install:didFailWithError:Error Domain=NSCocoaErrorDomain Code=516 ““nvvp.appâ€� couldn’t be moved to “libnvvpâ€� because an item with the same name already exists.” UserInfo={NSSourceFilePathErrorKey=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/4C266DDE-6197-436D-8D17-A3BDE76192E2.activeSandbox/Root/opt/pgi/osx86-64/2018/cuda/9.2/libnvvp/nvvp.app, NSUserStringVariant=(
Move
), NSDestinationFilePath=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/4C266DDE-6197-436D-8D17-A3BDE76192E2.activeSandbox/Root/opt/pgi/osx86-64/2018/cuda/9.1/libnvvp/nvvp.app, NSFilePath=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/4C266DDE-6197-436D-8D17-A3BDE76192E2.activeSandbox/Root/opt/pgi/osx86-64/2018/cuda/9.2/libnvvp/nvvp.app, NSUnderlyingError=0x614000247d40 {Error Domain=NSPOSIXErrorDomain Code=17 “File exists”}}
2018-11-19 16:26:00-07 MP-2 installd[2111]: PackageKit: Done with sandbox removals
2018-11-19 16:26:00-07 MP-2 Installer[2108]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
2018-11-19 16:26:00-07 MP-2 Installer[2108]: IFDInstallController 5510 state = 8
2018-11-19 16:26:00-07 MP-2 Installer[2108]: Displaying ‘Install Failed’ UI.
2018-11-19 16:26:00-07 MP-2 Installer[2108]: ‘Install Failed’ UI displayed message:‘The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.’.
2018-11-19 16:26:08-07 MP-2 Installer[2108]: Package Removal: User opted to keep package.
/var/log$

Did you have a previous installation of PGI at the same location? I.e. does /opt/pgi/osx86-64/2018/cuda already exist? I’m not aware of any installation issues, but you can probably move anything in that directory out to a different temporary location and let the installer copy over the files.

The same DMG (PKG) installs just fine on my ElCapitan laptop. Other install failure probably not the MacOS version but previous existing PGI and/or Cuda installations as you suggested.

Al