2nd GPU (RTX 3070) not Working in Ubuntu 20.04

I have 2x RTX3070 installed, both work in windows. In linux both graphics cards are showing up under ‘lspci | grep VGA’, but not under ‘nvidia-smi’.

I have attempted reinstalling Drivers, OS and enabling multigpu, basemosaic also running an empty Xorg.conf file to no avail.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (308.3 KB)

Please find the bug report attached

Please try setting the kernel parameter
pci=realloc
or set “above 4G decoding” in bios.

[ 0.310997] pnp 00:03: disabling [io 0x002e-0x002f] because it overlaps 0000:02:00.0 BAR 5 [io 0x0000-0x007f]
[ 0.310998] pnp 00:03: disabling [io 0x004e-0x004f] because it overlaps 0000:02:00.0 BAR 5 [io 0x0000-0x007f]
[ 0.310999] pnp 00:03: disabling [io 0x0061] because it overlaps 0000:02:00.0 BAR 5 [io 0x0000-0x007f]
[ 0.311000] pnp 00:03: disabling [io 0x0063] because it overlaps 0000:02:00.0 BAR 5 [io 0x0000-0x007f]
[ 0.311000] pnp 00:03: disabling [io 0x0065] because it overlaps 0000:02:00.0 BAR 5 [io 0x0000-0x007f]
[ 0.311001] pnp 00:03: disabling [io 0x0067] because it overlaps 0000:02:00.0 BAR 5 [io 0x0000-0x007f]
[ 0.311002] pnp 00:03: disabling [io 0x0070] because it overlaps 0000:02:00.0 BAR 5 [io 0x0000-0x007f]

[ 0.318899] pci 0000:02:00.0: BAR 1: assigned [mem 0x4010000000-0x401fffffff 64bit pref]
[ 0.318911] pci 0000:02:00.0: BAR 3: assigned [mem 0x4008000000-0x4009ffffff 64bit pref]
[ 0.318918] pci 0000:02:00.0: BAR 0: no space for [mem size 0x01000000]
[ 0.318919] pci 0000:02:00.0: BAR 0: failed to assign [mem size 0x01000000]
[ 0.318920] pci 0000:02:00.0: BAR 6: assigned [mem 0xc4280000-0xc42fffff pref]
[ 0.318921] pci 0000:02:00.0: BAR 5: assigned [io 0x5000-0x507f]
[ 0.318923] pci 0000:00:1c.0: PCI bridge to [bus 02]
[ 0.318925] pci 0000:00:1c.0: bridge window [io 0x5000-0x5fff]
[ 0.318927] pci 0000:00:1c.0: bridge window [mem 0xc4200000-0xc42fffff]
[ 0.318929] pci 0000:00:1c.0: bridge window [mem 0x4008000000-0x401fffffff 64bit pref]
[ 0.318932] pci 0000:00:1d.0: PCI bridge to [bus 03]
[ 0.318935] pci 0000:00:1d.0: bridge window [mem 0xc4100000-0xc41fffff]
[ 0.318940] pci_bus 0000:00: Some PCI device resources are unassigned, try booting with pci=realloc

[ 2.862540] nvidia 0000:02:00.0: enabling device (0000 → 0003)
[ 2.862659] NVRM: request_mem_region failed for 0M @ 0x0. This can
NVRM: occur when a driver such as rivatv is loaded and claims
NVRM: ownership of the device’s registers.
[ 2.862662] nvidia: probe of 0000:02:00.0 failed with error -1
[ 2.862673] NVRM: The NVIDIA probe routine failed for 1 device(s).

[ 0.318940] pci_bus 0000:00: Some PCI device resources are unassigned, try booting with pci=realloc

Try booting with the kernel parameter: pci=realloc

Or maybe you have a “Above 4G Decoding” setting in bios?

Also the card is running at 4x PCIe link speed, that’s a bit low. Any setting in bios you can change that, or another pci slot available with higher speed? Check your motherboards documentation.

Edit: oops generix was faster. sorry for a mostly redundant reply.

Hey there,

I have a similar configuration and problem getting my second 3070 GPU working. In my case, neither LSPCI nor nvidia-smi detect a second card.

I have verified that both cards work individually and I have verified that both cards are operational (together) under Windows.

Here is my bug report attached.

If I should be opening a new conversation - apologies - please let me know as I am new to the site.

Thank you,

nvidia-bug-report.log.gz (299.1 KB)

There’s absolute no trace of a second nvidia gpu handed over to the kernel by the bios.
What’s the pci id it gets assigned to by Windows?
Please update bios.

1 Like

Thank you generix. Let me get back to you on this asap and get the bios updated.

Hey Generix,

In my first run report from the install, you can see the two GPUS .

Here is the initial report from the Ubuntu install:

“Arch”: “amd64”,
“GPU”: [
{
“Vendor”: “8086”,
“Model”: “9bc5”
},
{
“Vendor”: “10de”,
“Model”: “2484”
}
],
“RAM”: 16.2,
“Partitions”: [
959.9,
0.5
],

Very puzzled why I can’t get to show up now.