3090 eGPU on Fedora... I've tried everything

Hello everyone,

I’ve recently switched to Fedora Silverblue from NixOS and Manjaro before that. On Manjaro, my 3090 was working fine in the eGPU. On Silverblue, it seems like no matter what I try I cannot get it working. It should be noted on Manjaro I had to use the open version of the module. The non-open version just would not work.

Things I’ve Tried:

  • I’ve installed the drivers from RPM fusion.
    • Tried kmod-nvidia with and without the X11 driver and X11 cuda driver.
    • Tried kmod-nvidia-open with and without nvidia.NVreg_OpenRmEnableUnsupportedGpus=1 and with and without the X11 driver and X11 cuda driver.
  • Tried both Wayland and X11.
  • Made sure everything was updated including the BIOS.
  • Made sure secure boot was disabled.
  • Read everything I could possible find.

I am having the issue where everything except nvidia-smi can see the GPU.

$ neofetch gpu
gpu: NVIDIA GeForce RTX 3090 
gpu: Intel Alder Lake-P 
$ lspci | grep NVIDIA
04:00.0 VGA compatible controller: NVIDIA Corporation GA102 [GeForce RTX 3090] (rev a1)
04:00.1 Audio device: NVIDIA Corporation GA102 High Definition Audio Controller (rev a1)
$ lspci -k | grep -A 2 -E "(VGA|3D)"
00:02.0 VGA compatible controller: Intel Corporation Alder Lake-P Integrated Graphics Controller (rev 0c)
	Subsystem: Device f111:0002
	Kernel driver in use: i915
04:00.0 VGA compatible controller: NVIDIA Corporation GA102 [GeForce RTX 3090] (rev a1)
	Subsystem: eVga.com. Corp. Device 3982
	Kernel driver in use: nvidia

$ lsmod | grep nvidia
nvidia_drm             94208  0
nvidia_modeset       1556480  1 nvidia_drm
nvidia_uvm           3493888  0
nvidia              62656512  14 nvidia_uvm,nvidia_modeset
video                  77824  2 i915,nvidia_modeset
$ nvidia-smi
No devices were found

dmesg is showing this:

[   26.102540] NVRM: GPU 0000:04:00.0: rm_init_adapter failed, device minor number 0
[   26.102852] [drm:nv_drm_load [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000400] Failed to allocate NvKmsKapiDevice
[   26.103044] [drm:nv_drm_probe_devices [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000400] Failed to register device

Any help would be greatly appreciated. I’m happy to provided anything else that is needed.

Thank you.


I have attached my bug report.

nvidia-bug-report.log.gz (307.9 KB)

Did you read this?


Thanks for responding.

I did not read that but it is nice to know that they are working on hot-plugging.


I do not think it applies to me. I am already in the habit of not hot-plugging and fully shutting down when I plug in the eGPU or unplug it.

In my case it isn’t a matter of the system being stable, it’s a matter of the drivers not being able to talk to the card. Or at least I think. I am not 100% sure that is why I posted here hoping someone who understands this a bit more than me might shine some light on this issue for me.

I use my GPU for work and currently having to use my girlfriends old machine while I’m working through this. And I not a huge Windows fan…