RTX 3060 not working on Fedora 37 Intel laptop

Hello, I will attempt to keep this as short as possible.

My GA106 in my eGPU does not work on my Intel laptop, no matter what distribution I use. The only time it has “worked” is when I booted the Fedora live USB, in which case, it displayed a workspace in both of my desktop monitors. However, the second I install Fedora 37 to my disk and install the nvidia drivers the supported way, it no longer works. Logging in to Gnome xorg kicks me back to the login menu, and I cannot login unless I select Gnome wayland.

Interesting things to note:
nvidia-bug-report.log.gz (512.7 KB)

  • The eGPU and GPU itself are recognized in lspci.
  • My thunderbolt devices are authorized on startup.
  • I do NOT have secure boot enabled.

NVRM: GPU 0000:04:00.0: RmInitAdapter failed! (0x26:0x56:1423)
Please check for a bios update. If that doesn’t help, use either driver 470.57-470.82 or the open kernel modules.

What would your recommended choice of action be in this case?

After trying all of your suggestions, nothing worked. It “partially works” as soon as I removed all nvidia packages from my installation, however.

Since you are using fedora, I guess both choices involve to use the runfile installer:
https://http.download.nvidia.com/XFree86/Linux-x86_64/