Blank screen Fedora 35 Nvidia driver 470.82.00

Hi, I just made a clean install of Fedora 35.

I have two GPUs in my computer:
1 Nvidia Geforce 3060Ti
2 Nvidia Geforce 2070 SUPER

I installed the Nvidia drivers manually using the guide here: Fedora 35/34/33 NVIDIA [495.xx / 470.xx / 390.xx / 340.xx] Drivers Install Guide – If Not True Then False.

Before showing the login screen the screen wents totally blank. Both cards worked fine before a kernel update from 5.13 → 5.14 on Fedora 34. I ended up doing a clean install but I’m totally stuck now.

Please, any input would be of value. I attach my nvidia debug log.

nvidia-bug-report.log.gz (1.0 MB)

The 3060 is failing:

[ 85.825357] NVRM: GPU 0000:09:00.0: RmInitAdapter failed! (0x23:0xffff:1204)
[ 85.825394] NVRM: GPU 0000:09:00.0: rm_init_adapter failed, device minor number 0

please check for properly connected power connectors, reseat card in its slot, check in another system (or swap slots) for a general hardware failure.

Thank you for getting back to me. When I remove the card and insert the 2070 SUPER card into the same slot everything works perfectly.

However, the 3060 is recognized correctly in BIOS and all lights and fans are started up nicely when I power up. See attached screenshot.

So, the only thing left is to go back to the store and see if I can use my warranty?

If you also tried changing power cords, you can only return it to vendor for warranty.