Mantiz eGPU w/ NVIDIA RTX3070 works with Dell Precision 5520, but not 5570

I’m getting the following messages in my journal log whenever Xorg inits. It fails to initialize the GPU although it shows up in lspci and it works with a Dell Precision 5520 laptop on Thunderbolt 3.

kernel: NVRM: GPU 0000:06:00.0: RmInitAdapter failed! (0x26:0x56:1423)
kernel: NVRM: GPU 0000:06:00.0: rm_init_adapter failed, device minor number 1

The Machine it works on is a Dell Precision 5520 with Thunderbolt 3

The Machine it does not work on is a Dell Precision 5570 with Thunderbolt 4

The eGPU is a Mantiz with an eVGA RTX3070 installed

I keep thinking there must be either a BIOS Setting that should off/on, or I am missing a kernel param that must be passed at boot for this to get working.

I have tried the follow boot params: nosimplefb, nomodeset, pcie_aspm=off, pci=nommconf

So far nothing has worked to get the eGPU to initialize with Xorg.

Does anyone have any ideas?
This laptop is very new so maybe there is a BIOS bug. I’ve had two BIOS updates in 2 weeks.


Known issue, requires either a bios update or using the nvidia open kernel modules instead.

@generix Good to know. Thanks for the information. I’ll press Dell for a BIOS update.