Can't see my second eGPU using nvidia-smi or through the GUI Nvidia Settings

When I run sudo lspci |grep -i nv, I can see both GPUs

00:14.3 Network controller: Intel Corporation Alder Lake-P PCH CNVi WiFi (rev 01)
03:00.0 3D controller: NVIDIA Corporation Device 1fb7 (rev a1)
22:00.0 VGA compatible controller: NVIDIA Corporation GA106 [GeForce RTX 3060 Lite Hash Rate] (rev a1)
22:00.1 Audio device: NVIDIA Corporation Device 228e (rev a1)

The RTX is an eGPU plugged into a laptop with an integrated T550 GPU.

Here is the nvidia bug report:
nvidia-bug-report.log.gz (1.1 MB)

RmInitAdapter failed! (0x26:0x56:1474)

I tried setting the kernel parameter nvidia.NVreg_OpenRmEnableUnsupportedGpus=1 but it didn’t solve the problem, should I try another driver version? as I’m using 530 driver, it doesn’t have the open version, at least in the additional drivers list.

Then choose another “-open” version.

It works with Nvidia 525.85.05 open, thank you.

I had to install 515.86.01 instead for cuda compatibility.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.