364.12 4K60 HDMI 2.0 fail

Loaded up 364.12 today to see if this problem (https://devtalk.nvidia.com/default/topic/901948/linux/gtx-970-355-11-on-fc22-refuses-to-recognize-tv-used-as-monitor-upon-display-sleep-resume-tv-resta/) has been fixed.

Was surprised to see that not only was it not fixed, any resolution over >30FPS at 3840x2160 on a Samsung TV fails to show anything at all.

While versions < 361.28 fail to re-establish a picture after the source disappears/changes, 364.12 doesn’t work at all. Has anybody seen the new beta driver work at 4K60 over HDMI 2.0?

I to have this issue using gtx950 and samsung js8500 tv if i have UHD colour mode (4:4:4 and 4:2:2) enabled the signal is lost all other drivers until this one worked fine.

still the same with 364.15

Yeah, 4k60 via HDMI 2.0 is not working for me either since 364.12 :(
Switching to DisplayPort works at 4k60 though.

hope this is fixed up on next release or i may have to go amd.

bump

Please provide make/model of this TVs you guys are using with hdmi 2.0 . Also attach nvidia bug reports.

@sandipt could this be related to my issue here https://devtalk.nvidia.com/default/topic/925605/linux/nvidia-364-12-release-vulkan-glvnd-drm-kms-and-eglstreams/ ?
I get vertical white lines as if the screen is stretched out in the beta driver with hdmi but no issue with stable driver.

hello sandipt the tv am using is a Samsung js8500 http://www.samsung.com/uk/consumer/tv-audio-video/televisions/suhd-nano-crystal-tvs/UE55JS8500TXXU am not sure how to do a bug report as when i load up with the driver it just says no signal also in the older drivers signal is also lost when changing to another input on the tv this is not the case with the windows driver.

What is the reproduction steps for this issue? I just have to plugin and plugout the hdmi 2.0 TV cable ? What is the resolution of TV - 3840x2160 30/60Hz ?

hi the signal is lost with uhd colour mode enabled http://support-us.samsung.com/cyber/popup/iframe/pop_troubleshooting_fr.jsp?homeid=543454&idx=545582 has been working fine with all other drivers until this one with the mode disabled the screen displays a signal but is all slow and choppy with the older drivers the signal was lost if you changed inputs on the tv such as hdmi 2 and so on when you changed back it said no signal its fine in windows.

I have the same issue with a Samsung U28E850.

I am running Ubuntu 16.04. All I have to reproduce is install and reboot. If I switch the display to 3840x2160 30Hz it works but 3840x2160 60Hz does not.

3840x2160 60Hz HDMI2.0 runs fine with 361.42.

Internal tracking bug ids :

  1. Bug 200193045 linux : fail to re-establish a picture after the source disappears/changes on Samsung TV 4K60 over HDMI 2.0

  2. Bug 200193033 linux : 364.12 4K60 HDMI 2.0 fail : any resolution over >30FPS at 3840x2160 on a Samsung TV fails to show anything at all.

  3. Bug 200193289 linux : when enabled uhd colour mode on Samsung TV with 364.12 driver getting single lost error. hdmi 2.0 4k tv

Hi Guys, Please attach nvidia bug report + GPU + os details + desktop environment[kde, gnome, unity etc] + Did you see this issue on any other TV/Monitor ?

hi not really sure what else to say can not do a bug report as i can not even log in due to the lost signal using these drivers the gpu am using is a 950gtx the os is ubuntu 16.04 gnome shell signal is lost at the point of lightdm load tried the new driver 364.19 and exactly the same problem.

hi i was just wondering if this is something that will be addressed in the upcoming drivers sucks not being able to use these new drivers.

this seems fixed now in 367.18 ultra hd colour mode working and i can now switch the tv off and back on and the picture comes right up great stuff thank you very much :)

yep its sorted can also change inputs with out loosing signal all we need now is hevc main 10 vdpau support :)

Thanks for testing, Yeah we have fixed this issue in 367 drivers. We’ll keep supporting and will fix major bugs.

thanks very much again much better experience using this screen now driver is running nice also no issues for me :)