Blank screen: 4k/60hz HDMI2 with 343.22

Hey everyone, I have been spending days on this issue without resolve. The monitor works in Windows8 at 4k/60 but using the same timings in Debian turns the screen blanks without any errors reported in the xorg log.

Nvidia driver: 343.22 on Debian Jessie
Card: 980gtx with high-speed hdmi cable | Display: 4k/60hz compatible Sony xbr49x850b

The details of the issue is here:
http://forums.debian.net/viewtopic.php?f=6&t=117757&p=554985#p554985

EDID or the working Win8 timings for the display do not seem to fix the issue. My guess is that the drivers for linux do not precisely set the output. This display will not show an image unless the numbers are precisely correct. Thanks for the help!

I’m guessing that the current linux drivers do not support HDMI2.0 fully yet. Any confirmations on this?

2nd generation maxwells are the first video cards to have hdmi2.0 outputs so it might be buggy. In your debian forums thread you made a modeline with cvt and it had out-of-spec max pixel clock, use -r option with it. Though I don’t think that would help either…

… But anyway, what you could try is to change color depth to 8-bit on nvidia-setting(somewhere I got the impression that hdmi2 support 4k@60Hz only at 8-bit color depth and panels are usually 10-bit tns). It should be on gpu-0->hdmi-0->controls tab.

tuke81, thanks for the help. However, forcing 8-bit still didn’t fix the blank screen issue sadly.

Hmm from manufacturer pages:

Try changing color range from full to limited(same control tab that color depth is).

Internally tracking this issue under Bug 200043559 : linux : HDMI 2.0:2nd generation maxwell:GTX 970/980: getting no-signal or blank-screen when attempted 4k resolution @60hz

How can I access the bug tracker? Do I need to create an account for it?

Just a small update, there’s been no fix for the issue yet for me. I’ve tried other Linux distros without success (including Ubuntu). Also I used the 343 drivers in debian experimental with still no luck.

The issue here is that the 4:2:0 color formats are currently not supported. A future driver release will reject those modes during mode validation and fall back to a supported mode.

“4:2:0 color formats are currently not supported” Ouch! That really hurts as I bought all this hardware and display for the ideal usage of 4k@0hz. Any idea on how long it will be to get it supported in the driver? Is there anything the community can do to help?

Does this mean Linux will not support a 4k 4:4:4 profile at all? or is it a limit for 4k 60hz?

Was this ever fixed? I see the latest revision is 346.35 and I was just about to buy a gtx980 + 4k lg tv

+1 I would really like to know as well. I have a 78 inch Samsung I’m using for a project and I get “No Signal” using the HDMI port unless I turn on one of the UHD HDMI color options which reduces chroma subsampling. I really need 4k@60 4:4:4 working pronto!!! We’re contractually obligated to deliver a solution and after fighting with the GTX 980 on linux for a few days I’m very tempted to go buy an AMD R9 and see if it’s any better.

Can you guys try 349.12, please?

Thank you guys.

I have struggled with xorg.conf on 346.47 driver to enable 4K@60p but could not get succeeded at all. But once updated the driver to 349.12 beta the problem gone.

Since color information is compressed to reduce bandwidth the small letters have some dirty edge but it is same as running Windows 8 on the same machine.

My environment is as below.

Ubuntu 14.04 64 bit
GeForce 750Ti video card
Sony KD-55X9200A connected via DVI to HDMI cable.