415.x 410.x 390.x Regression: GT 650M HDMI port detects display but does not output signal. Works wi...

On my macbook pro 2010 retina, the HDMI port hasn’t worked in a long time in linux. It detects the display but doesn’t send a signal out to the display. The DisplayPort ports work. The HDMI port works in windows and with the nouveau driver. I tried some different kernels and driver versions to see if I could pinpoint when the regression happened. I could only narrow it down to 340 series -> 390 series change.

system: MacBookPro10,1 (A1398)
processor: Intel® Core™ i7-3615QM CPU @ 2.30GHz
display: GK107M [GeForce GT 650M Mac Edition]

Works: (linux 3.2.0-99-generic)

  • 340.106 (2018-01-16)
  • 340.107 (2018-06-06)
  • Doesn’t work: (linux 4.15.0-39-generic)

  • 415.25 (2018-12-18)
  • 410.78 (2018-11-15)
  • 410.73 (2018-10-25)
  • 410.66 (2018-10-16)
  • 390.87 (2018-08-27)
  • Doesn’t work: (linux 3.2.0-99-generic)

  • 390.87 (2018-08-27)
  • 390.67 (2018-06-05)
  • 390.77 (2018-07-16)
  • 390.25 (2018-01-29)
  • 390.12 (2018-01-04)
  • 396.24 (2018-05-02)
  • 384.130 (2018-03-28)
  • I can’t get 340.107 to boot into a newer kernel but I will update the post if that works or doesn’t.

    A similar post with HDMI not working on a GT 650M but works with nouveau: https://devtalk.nvidia.com/default/topic/987658/linux/samsung-u28e590d-4k-geforce-gt-650m-out-of-sync-black-screen-linux/post/5056822/

  • nvidia-bug-report.log: https://www.dropbox.com/s/uqwws765tl17fes/nvidia-bug-report.log?dl=0
  • Xorg.0.log: https://www.dropbox.com/s/5m8htuqv1uqr3g8/Xorg.0.log?dl=0
  • Update:
    nvidia-bug-report.log on fresh ubuntu 18.04 with logverbose 6: https://www.dropbox.com/s/sdybytrhs7afyr0/nvidia-bug-report.log?dl=0

    Please check this:
    https://devtalk.nvidia.com/default/topic/1044770/?comment=5301278

    Thanks for the info. I tried the solutions there but it’s still not outputing…

    codyw@cody-macbook:~$ xrandr |grep ' connected'
    HDMI-0 connected 1920x1080+0+60 (normal left inverted right x axis y axis) 477mm x 268mm
    DP-2 connected primary 1920x1200+1920+0 (normal left inverted right x axis y axis) 331mm x 207mm
    
    xrandr --setprovideroutputsource modesetting NVIDIA-0 && xrandr --auto
    

    had no effect

    and there was no

    options nvidia-drm modeset=1
    

    in modprobe.d/*
    I tried adding

    options nvidia-drm modeset=0
    

    in a new .conf file and did updateinitramfs and reboot but still no output.

    Update: Still no HDMI output with the new 410.93 (the monitor is still detected)

    (I saw “Fixed a bug that could prevent display detection from working on displays connected to some notebook docking stations.” in the release notes but it did not solve my problem.)

    You have a mismatch of glx module (1.18) and xserver (1.19), you should reinstall the xserver package.
    The nvidia-bug-report.log is empty, not helpful. I suspect you’re using Ubuntu 16.04, did you try to run with a xorg.conf?
    i.e. add nogpumanager kernel parameter, then create an /etc/X11/xorg.conf

    Section "Device"
        Identifier     "nvidia"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BusID          "PCI:1:0:0"
        Option         "AllowEmptyInitialConfiguration"
    EndSection
    

    Thanks for the info. Sorry for the delay responding, I wiped out my bootloader installing ubuntu on a USB drive :)

    Anyway, I installed a fresh Ubuntu 18.04 and fully updated it. Installed 410.93 and ran startx with logverbose 6 and got a proper nvidia-bug-report.log:

    Still the display is detected and enabled in nvidia-settings but no output to the screen and no error in the log file.

    I also tried adding ‘nogpumanager’ to the kernel arguments and created the xorg.conf you supplied but still no output :(

    (The same kernel/port/cable/monitor works with the nouveau driver)

    Update: (still not working)

    with kernel 4.15.0-74-generic,

    Driver Result
    nouveau works, but only from boot (can’t hotswap)
    340.108 works
    390.132 detects HDMI monitor and extends desktop, but as before doesn’t send a signal to the monitor (monitor goes to sleep)
    418.88 same behavior as 390.132
    440.44 same behavior as 390.132

    If I get a chance I’ll run nvidia-bug-report with the different drivers and try and find what is different.

    I use the same card and encounter the same problem with 450.66 on Manjaro.

    i have posted more details here

    1 Like

    So for this video card the latest driver 340

    yeah but you might have problems with the newer kernels. Not sure.