4Kp30 Transcoding (nvv4l2decoder -> nvv4l2h265enc) is failed on Jetson Nano

filesrc_nvv4l2decoder_nvv4l2h265enc_pl1_fakesink_4kp30_error.log (1.7 KB) Hi,

I am trying to run the Transcoding (decode -> encode) pipeline and i am getting following errors

  • ERROR: from element /GstPipeline:pipeline0/nvv4l2h265enc:nvv4l2h265enc0: Failed to process frame.
  • Maybe be due to not enough memory or failing driver

I am using below pipeline:
GST_DEBUG=“GST_TRACER:7” GST_TRACERS=“interlatency” GST_DEBUG_FILE=filesrc_nvv4l2decoder_nvv4l2h265enc_pl1_fakesink_4kp30.log
gst-launch-1.0 filesrc location=AIR_4Kp30_nv12.h264
! h264parse
! nvv4l2decoder enable-max-performance=1 disable-dpb=true \
! nvv4l2h265enc preset-level=1 MeasureEncoderLatency=1 maxperf-enable=1
! fakesink

I am getting same error when i tried streaming use-case also.
GST_DEBUG=“GST_TRACER:7” GST_TRACERS=“interlatency” GST_DEBUG_FILE=udpsrc_nvv4l2decoder_nvv4l2h265enc_pl1_fakesink_4kp30.log \gst-launch-1.0 udpsrc port=50000 buffer-size=2000000 caps=“application/x-rtp , media=video, clock-rate=90000, payload=96, encoding-name=H264” \ ! rtpjitterbuffer \ ! rtph264depay \ ! nvv4l2decoder enable-max-performance=1 disable-dpb=true \ ! nvv4l2h265enc preset-level=1 MeasureEncoderLatency=1 maxperf-enable=1 \ ! fakesink

I have attached the error log for reference.

Does the 4kp30 transcoding use-case supported on Jetson nano ?
Please let me know correct pipeline and parameters if 4Kp30 transcoding is supported.

Thanks for your support/help.

Regards,
Damoder

Please refer to Max fps MJPEG to H.264/5 transcoding to see if can help.

Hi,
Please check if you can run this:

Your input files look to be H264 stream, which doesn’t have timestamp information. Suggest you try with mp4 or mkv files.