8800GTS 512MB and CUDA-which driver?


I just got my BFG 512MB 8800GTS today, installed the appropriate drivers, and boy was I happy to play Crysis on high settings!

Then I wanted to test out the CUDA programs that were working just fine on my 320MB 8800GTS which I had been using previously, but they weren’t working! It says “An unhandled win32 exception occurred in name.exe”

The sample executables found in bin/win32/Debug or release give the same error, and when I tried running a code that I wrote, it fails when I try to allocate device memory.

I downloaded the 169.09 beta, but it says it could not find any drivers that supported my hardware.


The 169.09 beta didn’t support the 8800 GTS 512MB.
Download the new 169.21 to get support for the 8800 GTS 512 MB.

Thanks, for some reason I didn’t see that driver.

I installed the 169.21, but I’m still getting the same error when device memory allocation is done. Do I need to reinstall anything else?

Are those programs compiled with CUDA 1.0? If so you should recompile with 1.1.

BTW, are samples from 1.1 SDK are working or not?

I installed the 1.1 SDK and the toolkit like you suggested. After recompiling, everything seems to be working properly.