8880 GTX + on-board VGA adapter

Hi all.
There is on-board videocard on my Intel motherboard and I’ve just got GTX 8800 video card, which is connected to PCI-E slot now.
Can I use on-board adapter as primary videocard in order to use 8800 GTX only for CUDA computations?
If yes, what settings should I use?

(Now on-board adapter is set as primary videocard and CUDA samples do not launch: “There is no device supporting CUDA”).

May be it is important - I use Win XP.

Thank you.

Unfortunately it seems to be impossible on Windows XP. I’ve had similar problem and was not able to have both display adapters recognized by Windows. Probably this is limitation of Windows XP. It seems that it cannot have more than one display driver loaded at a time.

Andrei, thanks.
It seems you’re right.

the rule about doth devices using the same driver seems to apply whether you are talking 2 add in cards or onboard with an add in card

You are right, of course. But I haven’t seen motherboards with onboard GeForce8 yet.

FWIW: Here is another post where someone was trying to get an ATI card to be the primary display device while using a G80 for CUDA. Unfortunately they met with the same luck.

http://forums.nvidia.com/index.php?showtopic=41681&hl=radeon

Has anyone tried using an old PCI card, your driver limitations may be per bus type.
My ASROCK M/B can use PCI,AGPand PCI-E at the same time for a surround display.
It does say you must load drivers in AGP-PCIE-PCI order with restarts between driver installs.
I don’t have a PCI-E to test this myself.

Tried old PCI video (Matrox). My 8600 GTS is present in device manager but CUDA calls fail with “initialization error”. And the only CUDA device which is reported by deviceQuery SDK utility is gpu emulation device.

Maybe if you expand the windows desktop to the 8600 GTS.

iirc the limitation is due to addressing and interrupts, not interface type

If your PCI card is also Nvidia’s, it is Ok.

I have an integrated nForce 610 working with an 8600.

The thing to remember is

CHANGE THE BIOS SETTINGS!

these typically disable the onboard card when an addin is detected.

That won’t fix other problems, but there’s a couple things you can try. If it’s about interrupts, try changing PCI slots or setting IRQs manually (in the bios or in windows). There’s also often a setting which asks which card to turn on first during boot-up. Also you can try setting the 8x00 as ‘primary’ in windows. Also reinstalling drivers. I’ve had ATI+NVIDIA cards churning 3D together before, but haven’t tried CUDA. It might be especially finicky.