8K60 output with RTX 3070 and Samsung Q900TS over HDMI 2.1

Hi,

The last several months I have been trying to get 8K60 output on Linux. First through a Club3D DP 1.4->HDMI 2.1 active adapter, then with an RX 6800 over HDMI 2.1 as I couldn’t get my hands on an RTX 3xxx. Now I finally managed to get my hands on an RTX 3070 figuring my fruitless attempts of getting 8K60 output on Linux pay off and it’s just plug and play as it is on Windows 10. Unfortunately not but at least the NVIDIA drivers have been helpful of providing more in-depth information of what is going on, yet I don’t know how to proceed next.

What I am using:

  • Gigabyte AORUS GeForce RTX 3070 Master 8G
  • Gigabyte B550 AORUS Elite AX V2
  • AMD Ryzen 5 5600X
  • Samsung Q900TS 65" (QE65Q900TSLXXN) over HDMI 2.1
  • Arch Linux (5.10.11 kernel)
  • NVIDIA 460.39 driver (from repository, pacman)
  • Xorg server 1.20.10

What is working so far

  • 4K120 and 8K60 (both RGB and 4:4:4 according to NVIDIA control panel) on Windows 10
  • 4K120 and 8K30 on Linux, readily available to select, plug and play, verified working 120Hz through OSD.

What I have done and found so far
In the Xorg log file I then found this after enabling debuggin information:

[     8.066] (WW) NVIDIA(GPU-0):   Validating Mode "7680x4320_60":
[     8.066] (WW) NVIDIA(GPU-0):     Mode Source: EDID
[     8.066] (WW) NVIDIA(GPU-0):     7680 x 4320 @ 60 Hz
[     8.066] (WW) NVIDIA(GPU-0):       Pixel Clock      : 2373.62 MHz
[     8.066] (WW) NVIDIA(GPU-0):       HRes, HSyncStart : 7680, 8232
[     8.066] (WW) NVIDIA(GPU-0):       HSyncEnd, HTotal : 8408, 9000
[     8.066] (WW) NVIDIA(GPU-0):       VRes, VSyncStart : 4320, 4336
[     8.066] (WW) NVIDIA(GPU-0):       VSyncEnd, VTotal : 4356, 4400
[     8.066] (WW) NVIDIA(GPU-0):       Sync Polarity    : +H +V 
[     8.066] (WW) NVIDIA(GPU-0):     Unable to determine HDMI 2.1 Fixed Rate Link
[     8.066] (WW) NVIDIA(GPU-0):     configuration.
[     8.066] (WW) NVIDIA(GPU-0):     Mode is rejected: Unable to construct hardware-specific
[     8.066] (WW) NVIDIA(GPU-0):     mode timings.
[     8.066] (WW) NVIDIA(GPU-0):     GPU extended capability check failed.
[     8.066] (WW) NVIDIA(GPU-0):     Mode "7680x4320_60" is invalid.

But 8K30 is listed as valid:

[     8.066] (II) NVIDIA(GPU-0):   Validating Mode "7680x4320_30":
[     8.066] (II) NVIDIA(GPU-0):     Mode Source: EDID
[     8.066] (II) NVIDIA(GPU-0):     7680 x 4320 @ 30 Hz
[     8.066] (II) NVIDIA(GPU-0):       Pixel Clock      : 1186.81 MHz
[     8.066] (II) NVIDIA(GPU-0):       HRes, HSyncStart : 7680, 8232
[     8.066] (II) NVIDIA(GPU-0):       HSyncEnd, HTotal : 8408, 9000
[     8.066] (II) NVIDIA(GPU-0):       VRes, VSyncStart : 4320, 4336
[     8.066] (II) NVIDIA(GPU-0):       VSyncEnd, VTotal : 4356, 4400
[     8.066] (II) NVIDIA(GPU-0):       Sync Polarity    : +H +V 
[     8.066] (II) NVIDIA(GPU-0):     Viewport                 7680x4320+0+0
[     8.066] (II) NVIDIA(GPU-0):       Horizontal Taps        1
[     8.066] (II) NVIDIA(GPU-0):       Vertical Taps          1
[     8.066] (II) NVIDIA(GPU-0):       Base Formats           0x1ffffefff
[     8.066] (II) NVIDIA(GPU-0):       Overlay Formats        0x1ffffefff
[     8.066] (II) NVIDIA(GPU-0):     Mode "7680x4320_30" is valid.

I have tried forcing the new mode using XRandR and adding the modeline to Xorg config but to no avail:

xrandr --newmode "7680x4320_60" 2376 7680 8232 8408 9000 4320 4336 4356 4400 +HSync +VSync
xrandr --addmode HDMI-0 "7680x4320_60"

I have tried skipping the mode validation and ignoring the EDID checksum as you can see in my Xorg configuration but that doesn’t seem like the right way to force things. Clearly something is “broken”. I have been at this for hours and all I got was either this message in the Xorg log or a blank screen.

Almost forgot, I even enabled KMS and Wayland to see if it made any difference, doesn’t work either. Same resolutions available.

Could really use some help at this point. It’s no problem to use some some custom drivers, apply some patches, compile it myself or anything. I’m just drawing a blank on what to try next.

Fyi this will be my development workstation running PhpStorm and Docker, I don’t need any games running as I’ll just boot to Windows 10 for that.

Xorg log file
Xorg.0.log (344.2 KB)

My Xorg configuration
10-nvidia.conf (835 Bytes)

1 Like
Unable to determine HDMI 2.1 Fixed Rate Link configuration

Sounds like the driver and display can’t agree on DSC being used. Since that’s low-level, Nvidia devs have to look into this.
It’s puzzling though that no 8k@30,24 modes show up. Please also post the output of
xrandr --verbose

1 Like

8K24 and 8K30 do show up, I have attached the whole Xorg log which lists those as well. This provides more details than XRandR :)

4K120 and 8K30 work fine, forgot to mention 8K30 in my post, edited. Sorry about that.

Ok, thanks for clarifying, from your first post I got the impression that 8k@30 wasn’t selectable despite being displayed as valid.
So I guess the driver ‘only’ has some issue with DSC. Of course, this is really just speculation.
Maybe also send your logs to linux-bugs[at]nvidia.com for increased attention.

1 Like

I have sent an email to that address, I hope someone can shed a light on this on where to look.

Also sad to see the Nouveau driver isn’t updated regularly and has no support for the RTX 3000 series yet.

As this isn’t resolved yet, I am wondering the following:

My card has 3 HDMI ports of which 2 are HDMI 2.1 and one is 2.0 I believe. Even though 8K60 is indeed working on the current port on Windows, I was wondering if switching ports would help and the HDMI version / bandwidth is determined by the drivers instead of the hardware in this case. Far fetched but maybe the driver enumerates the ports the other way around (port 1 being 3 on Linux or vice versa).

Normally the 3070 only has one HDMI 2.1.

Might give it a go today as looking at a 65" 30Hz slideshow is driving me nuts.

Small update, switching outputs didn’t help, with or without xorg.conf modifications. Today I installed 460.56 and this totally messed everything up so bad even with no xorg.conf modifications. Screen freezes randomly and sometimes completely freezes everything permanently until I reboot.

I gave up for now and switched back to my RX 6800 as I have work to do. I’ll have another go if someone responds or the next update is released.

I’ve got the same problem but with a 3090 and Samsung Q600. Windows does 8k60 just fine but Linux (Kubuntu 20.04 - fully up to date with ‘stock’ apt nVidia drivers) only goes up to 8k30.

same problem on samsung rtx 3090 linux samsung g9 no 240Hz support no 10bit

I’m encountering the same issue with a MSI 3070 on Fedora running the latest 465.27. The display is a LG 55" 8K Nano95.

Hoping that Nvidia implements DSC for their Linux drivers soon.

Just curious, are you getting 8K60 on your RX 6800 under Linux?

Just to confirm that using a Club 3D CAC-1085 DP 1.4 to HDMI 2.1 adaptor results in a 8K30 max resolution as well on my 3070, pointing to an issue with DSC.

1 Like

I have an RTX 3090 with Samsung QN800A here. Only getting 30 Hz at 7680 x 4320 also T__T.

The only reason why I bought this setup is to be able to do 8K60 and now it seems it is impossible. NVIDIA 465.31, Arch Linux, RTX 3090 Founders Edition. Using a pricey Certified 8K HDMI 2.1 cable from Monoprice.

1 Like

No, 8K60 isn’t working with the RX6800 either. This isn’t really an nvidia problem as it turned out, well kinda. It appears nobody has implemented DSC or possibly FRL support or anything 2.1 related in their drivers as the HDMI forum forbids implementation in open source drivers.

So AMD can’t implement it, not that easily anyway as their driver is open source. Nvidia can afaik but for some reason don’t.

I really wish that 8K displays with DP become mainstream and TV manufacturers would drop HDMI. Also wished that 8K TVs would allow for 4x HDMI 2.0 in to make a 2x2 matrix of 4K inputs.

2 Likes

Interesting. I was expecting that this would be in hardware and firmware so that any driver code would just be initialisation. etc. But Nvidia should have no issues here in any case. Did you get any confirmation that they are working on this? If not, maybe we need to open a bug report.

Yes I too would like to know if anyone is working on this. This is an extreme barrier to productivity for me at the moment.

1 Like

Tested on latest Linux beta driver 470.42.01 and the issue remains. No 8K60 output at all, but works OK at 8K30.

What a bummer, thanks for testing it out. Hopefully 8k 60 Hz will work in the next version… my eyeballs have literally atrophied and dried up like raisins from looking at 8k 30 Hz.

1 Like

Updated to 470.57.02 and still no joy. Is there anybody from Nvidia that can chime in on if this is in the pipeline?

Here on nvidia 470.63 there is still no 8K60… only 8K30 or 4K120. I wish someone at nvidia would acknowledge the issue.