A hierarchy of objects moved seperately by the randomizer

Hello everyone,

I am new to omniverse, and trying to create training-data with a scene that has 2 objects in a hierarchy. They should move & rotate together (as the y do interactively), but when I run the replicator they move seperately. Anyone has an idea why?

I attached the omniverse-screen with the stage + script + basic-scene and 2 produced train-images

Thanks in advance


Hello @rami.mayer1 ! I’ve passed along your questions to the Replicator Team.

If it helps, here is a link to our instructional documentation: Replicator Isaac Extension [omni.replicator.isaac] — isaac_sim mr3140 documentation
and also a link to the Replicator API: Omni Replicator — omni_replicator 1.6.4 documentation


Hi @rami.mayer1 , rep.get.prims will get you all the prim under that path. Can you try to use rep.get.prim_at_path?

Hi, and Thanks for the fast response.

I am getting (with rep,get.prim) all the 4 objects under the path (“drill” in my case), but they move SEPARATELY with a different randomization values. I don’t find “rep.get.prim_at_path” in the documentation (I use API — omni_replicator 1.5.1 documentation ) am I missing it, or is there a newer version of the documentation?)




all the objects under

Hmm, the get.prim_at_path should be in in 1.5.0. The documentation is not updated. Can you check here?

I moved to use “rep.get.prim_at_path”, and now it works!