A40 Displaylink Output

I am currently working on a HPC system that uses an A40 array of GPUs… i have run the display mode tool to mode 2 (8gb) and one card to mode 0 and switched the cards to FDM 0…but the displaylink ports still wont output…is there a setting i missed in smi like the gom mode? Or is there a DP driver i need? I am working in a non networked location so im limited in pulling down drivers via internet.


Hello @minisandpirate and welcome to the NVIDIA developer forums!

Did you closely follow the instructions in the user Guide for the tool? There you will find which drivers are supported for which modes as well as the impact of setting FDM.

There might also be a typo in the docs where it states

Physical Display Ports Disabled with 64GB BAR1

A40 only has 48GB, so this comment does not make sense. I need to check, but the mode 2 might actually conflict with the A40 or disable DisplayPort support. Did you try without setting any gpumode?


I did notice the typo, but i do see when i select the mode its 8GB vs 64. And i have followed the instructions to the letter and in the smi it shows the cards are in WDDM mode but despite all of that plugging a displaylink cable into the GPU it will not turn on the display. I found switching it to mode 0 which is the 256MB Workstation mode the ports do show in the control panel but plugging a monitor in wont show. I did notice looking at the topology page it shows the ports are there but has no EDID file, is that something that is needed to turn the monitors on?

Thanks again

Roger Seeley

Well, yes, EDID is needed for the GPU to know the capabilities and timings of the attached monitor. I am surprised that you don’t see any.

I guess you have ruled out defective or too long cables?

I am a bit at a loss right now, I will try to get some more eyes on this, but no promises.

As to troubleshooting I would start from scratch and only use a single GPU to start with and get that to display. Only then start adding additional GPUs

I have tried cables of different sizes and no change… i have gone into the control panel and verified in fact the ports are showing. When i exported a edid file from a p1000 card and imported it into the a40 the smi shows the port is now on but it wont export. I am not sure if there is a generic edid file i could upload or one specific to the A40… one issue i have is since i work in a non networked environment i am limited in what i can do. It took quite a bit of time to figure out the initial issue with the cards themselves its just this last bit to get them to behave like a graphics card in a workstation setup.

On a side note does the same tool have to be used on Linux?

The tool is distributed with both a Windows and a Linux binary. So yes, you can use it in Linux as well.

Otherwise no further news from my side I am sorry to say.

so i have a odd question… how does the display tool work on ubuntu 22.04 and RHEL 8? I have the folder on the desktop however everything i have tried to make it work hasnt. I verified the GPUs show in SMI but no commands i have tried will get the tool to work… and hints or tricks on that? there are two icons one is the .exe and the other is just a simple displaymodeselector

also something kind of odd when it comes to windows… and because this is such a unique system im not sure where this issue might lie… on Win 10 Pro i will change the GPUs to WDDM and everything works… but i will shut the system down and when i come back Windows will not show all of the GPUs… its like some of them disappear after the change

So you mean this command
sudo ./displaymodeselector --gpumode
does not change anything or does it not even run?

As to the Windows behavior that is weird indeed. Although not unheard off that Windows stores certain Display configurations and silently fails if it does not find them on restart in exactly the same way or order.

I will give that a try though i think i have… is there any special place that folder has to sit in the system? I currently have the downloaded file on the desktop

No, you can execute the app from anywhere. Only requirement is to have admin privileges.

So i got the app to finally execute…but i was met with an error about disabling nvidia services before it would let me run…i have a screen shot of the error i can post in a bit

on a side note… how do i change how the card behaves? i have a few i have in desktop mode and i need to do some rendering and fps related things… are there settings or profile changes i need to make to bring those settings up?

I am not sure I understand what you mean with

how do i change how the card behaves
Maybe if you explain a bit more detailed what you want to achieve?

Also, You did not share that screenshot of the error message.

What i mean is using programs like Unreal Engine or another type of rendering software i was just wondering if there are profile changes you can make in the card so that it behaves more like a desktop graphics card vs data center?

nvidia (2)
this is the error i get on ubuntu when trying to use the display tool… i get the same issue on rhel as well… windows does just fine

What i mean is using programs like Unreal Engine or another type of rendering software i was just wondering if there are profile changes you can make in the card so that it behaves more like a desktop graphics card vs data center?

Thanks, got it. But no, there are not. These GPUs are not designed for use as a “normal” Desktop card.

Regarding the second part, in order to rmmod (remove modules) they need to be un-loaded. Since you are still in the GUI (gnome-desktop-terminal, correct?) the GPU is in use and you cannot unload its kernel modules. You need to boot in text only mode to be able to use the tool.

One more piece of information I found. A40 GPUs seem to have all physical display outputs disabled in factory defaults. You might first need to enable them by setting the driver model to WDDM through nvidia-smi as well. Should be nvidia-smi -dm 0

Sounds good… its what i figured but then again the display option was sort of a later ask of my customers…

I see where they made changes to the display mode selector tool… is there a way to get some insight on any changes they made to the software?

Sorry, but no. Since this is a “per-request” tool and not provided publicly, it does not come with public changelog or similar.