About L4T quick start guide and deep stream sdk

Hello,

The above is the process of flashing Jetson in the L4T quick start guide.

The Jetson module is in use, and the carrier board of the Dev kit is used.
Previously, Flashing was done through SDK Manager.
This time, I’m going to follow the quick start guide.

When using the Dev kit itself, I used to burn an image on an sd card.
In this case, deep stream sdk could be installed only through SDK manager.

Is it possible to run the deep stream sdk example even if it is installed in the quick start guide?

If not, how can I install deep stream sdk if I follow the quick start guide?

Thank you.

The DeepStream SDK only can be installed by SDK manager, afterward then can run those samples.

1 Like

I know that massflash through sdk manager is not currently supported.
So how do you install deep stream sdk when massflashing?

Thank you.

You will need to prepare a custom image which includes all developed application and custom changes for your product, then it will be used as the SW image to do massflashing at production line.

@neuezeal

Hello fellow doggo. You can install deepstream in a chroot from .deb package and master the image as suggested by @kayccc . Instructions are in the l4t docs. This has worked for me in the past. I suspect when the GA release comes around it’ll be available in the apt repos like deepstream-4.0 was, making this even easier.

1 Like

I am just wondering what are the arguments to install DeepStream SDK with headless sdkmanager installation for jp4.4, if any.

Hi,

For dependency of each package, we would suggest install through SDKManager. Or you may install debian packages.

through SDKManager with GUI, or without the GUI [headless]? both or only one of the two will work? if the headless SDKManager can install deepstream - what are the arguments required to do so?

Last I used SDKM, it still required X11 even at a terminal, so I gave up on that. I love Nvidia products but SDKM has too many issues for me.

  • Cli mode, last I checked, still required X11
  • it requires registration (gigantic pet peeve)
  • anything it can download can also be found through apt on the Nvidia website.
  • It tries to do too much
  • It only works on Ubuntu 18
  • 10 other concerns/bugs here

It’s essentially GeForce Experience for developers, which isn’t always a bad thing. I mean I like GeForce Experience, but I don’t need/want it in a development environment, much of which may be automated. Ymmv.

I was very happy with the move towards OTA updates and hope that continues, whether through apt or snap or flatpak or whatever.

it is not the case as long as headless mode is being used

Is headless a command line --flag for SDKM? I haven’t tried it. If it’s fixed I’m glad, but the other issues stand and are still deal breakers for me, at least.

Does it still require login credentials at the command line? How are they supplied? Stdin?

sudo sdkmanager --cli install --user me@mail.com --logintype devzone --product Jetson --version 4.4 --targetos Linux --target P3668-0000 --flash all --targetimagefolder /home/user/nvidia/installation_nx --downloadfolder /home/user/Downloads/nvidia
sudo sdkmanager --cli install --user me@mail.com --logintype devzone --product Jetson --version 4.3 --targetos Linux --target P2888-0001 --flash all --targetimagefolder /homepath/Downloads/nvidia/installation_agx --downloadfolder /home/path/Downloads/nvidia
etc

I think you have to be registered already through the GUI for that to work. In my case this precludes automating the process in Docker/VM without ugly hacks I am not willing to make. And even if I did that a bug prevents SDKM from remembering my credentials.

To me it’s just too complicated. It tries to do too many things, which are solved better with package managers that have been battle tested for 20+ years. Apt-get isn’t perfect but it’s pretty good and people coming from Pi or other Linux are used to it. It’s the industry standard solution.

it is a wrong assumption, as it seems to me

I will experiment with it later at some point in a VM @Andrey1984 . I haven’t used it in ~6 months. I can’t imagine it lets you supply any --user without login.