Installing DeepStream 4 on Nano

I am trying to install DeepStream SDk on my Jetson Nano (dlinano image (20gb)). I cannot load the SDK manager on the nano (Jetpack 4.2) and because my host machine is ubuntu 20.04 (not 18.04) it does not allow me to select the target system. So I downloaded the ,tar file and tried to extract per instructions and get the following stream of terminal information.
dlinano@jetson-nano:~/Downloads$ sudo apt-get install ./deepstream-4.0_4.0.2-1_arm64.deb
[sudo] password for dlinano:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘deepstream-4.0’ instead of ‘./deepstream-4.0_4.0.2-1_arm64.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
deepstream-4.0 : Depends: libnvinfer6 (>= 6.0.1) but it is not installable
Depends: libnvinfer-dev (>= 6.0.1) but 5.0.6-1+cuda10.0 is to be installed
Depends: libnvparsers6 (>= 6.0.1) but it is not installable
Depends: libnvparsers-dev (>= 6.0.1) but it is not installable
Depends: libnvonnxparsers6 (>= 6.0.1) but it is not installable
Depends: libnvonnxparsers-dev (>= 6.0.1) but it is not installable
Depends: libnvinfer-plugin6 (>= 6.0.1) but it is not installable
Depends: libnvinfer-plugin-dev (>= 6.0.1) but it is not installable
E: Unable to correct problems, you have held broken packages.
dlinano@jetson-nano:~/Downloads$ cd
dlinano@jetson-nano:~$ sudo apt-get install libnvinfer6
[sudo] password for dlinano:
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libnvinfer6

So it appears the image doesn’t have some of the dependencies needed and I can’t get to the repositories. I have an A board rather than a B board. Can anyone help?

Hi kentnsmithllc,

The DeepStream-4.0 need install JetPack-4.2.1 and all sdk components.

To successfully use the DeepStream SDK, the following additional components must be installed and set up on the target system:

  • CUDA (10.0)
  • TensorRT (5.1+)
  • OpenCV (3.3.1)
  • VisionWorks (1.6)

You can install these packages using JetPack SDK Manager.

SDK Manager cannot be loaded on the nano for some reason and my host computer is Ubuntu 20.04. It does not work properly on that version of Ubuntu. It will not allow the target machine to be loaded. The SD card image is JetPack 4.2.

Kent N Smith

Kent N Smith Consulting Services LLC

1-352-445-1409 (cell)

Hi kentnsmithllc,

Host machine support Ubuntu Desktop 16.04 and 18.04 on x64 system.

If upgrading is an option, on jetpack 4.3 you can just sudo apt install deepstream-4.0 and deepstream-5.0 on JetPack 4.4.

The dli image hasn’t been updated in a long time but all of the software on it is also available in the online apt repositories. Then there is no need for SDK Manager. I uninstalled it, personally.

Thanks @mdegans update.
Yes, you can use below command line to install sdk components:

sudo apt-get update sudo apt-get install nvidia-jetpack
$ sudo apt-get install deepstream-4.0

Command line update is start from JetPack-4.3 (deepstream-4.0) and JetPack-4.4 (deepstream-5.0)

Thanks for the replay. Still a few questions.

I imaged a new SD card with the latest release. Looked at nv-tegra-release – L4T version appears to be 4.2.

I updated and installed nvidia-jetpack via command line and nv-tegra-release still says L4T version to be 4.2.

I haven’t tried to install deepstream yet but how can I update to Jetpack 4.3 or 4.4 or am I already there and don’t know it

Kent

So I do all you just said and get a could not find deepstream-4…0 package error.?

Kent

I get the following message for deepstream download

kent@kent-nano1:~ sudo apt-get install deepstream-4.0 [sudo] password for kent: Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package deepstream-4.0 E: Couldn't find any package by glob 'deepstream-4.0' E: Couldn't find any package by regex 'deepstream-4.0' kent@kent-nano1:~ sudo apt-get install deepstream-5.0
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package deepstream-5.0
E: Couldn’t find any package by glob ‘deepstream-5.0’
E: Couldn’t find any package by regex ‘deepstream-5.0’
Kent

My understanding is that a backup of your important files and a reflash of a standard JetPack image are required to update from 4.2. If you have a devkit you can just flash an SD card image using Etcher.

Since 4.3, OTA updates with apt-get are supported.

I just reflashed the SD card this morning with the image I downloaded this morning from the nvidia JetPack web site. How do I get the latest 4.3 or 4.4 Jetpack image?

Kent

I just downloaded the file again the file name is nv-jetson-nano-sd-card-image-r42.4.2(1).zip. It appears to be versin 4.2 not 4.3. I used the download link on the JetPack 4.3 site. Is the link pointing in the correct location?

Kent

carolyuu,

I just re-downloaded the Jetpack from the nvidia web site “get Jetpack SD card Image” on the JetPack 4.3 page and it appears to link me to JetPack 4.2 SD card image. Could you e-mail me the correct link to the JetPack 4.3 (or 4.4) SD card image so I can re-flash my SD card to the latest image???

Also perhaps you can fix your website link.

kent

I just re-downloaded the file and got this file nv-jetson-nano-sd-card-image-r32.3.1.zip which appears to be an older file than the last one???

I use this link and get nv-jetson-nano-sd-card-image-r42.4.2.zip which is dated 4/29/2020 when I unzip it.

My apologies to all. I just ran sudo apt-get install nvidia-jetpack on my machine and the output said nvidia-jetpack is already the newest version (4.4-b144). Of which I assume it is JetPack 4.4 build 144. Again my apologies. It appears I do have the latest JetPack downloaded. I will try again to load DeepStream SDK.

If you have 4.4 you should be able to sudo apt install deepstream-5.0

Sources and sample code are in /opt/nvidia/deepstream/deepstream

Carolyuu

I have gotten the jetpack 4.4 installed on my SD card now but

when I run sudo apt-get install deepstream-5.0

I get

Couldn’t find package by glob ‘deepstream-5.0’

Couldn’t find package by regex ‘deepstream-5.0’

It appears I don’t have the correct repository on my repo list.

How can I resolve that?

Kent

Sorry. I was misinformed. It looks like it was pulled from the online apt repos or misremembered it being there. You may have to download the Debian package.

4.0 should still be in the JetPack 4.3 Repos, so sudo apt install deepstream-4.0 should still work on that version of JetPack.

Hi kentnsmithllc,

Please download DeepStream files with " DeepStream 5.0 for Jetson".

sudo apt-get update
sudo apt-get install ./deepstream-5.0_5.0.0-1_arm64.deb

Thanks @mdegans :)