Access CAN-1..CAN-4 from Tegra on DRIVE PX 2

The DriveWorks 0.2.1 documentation for “CAN Bus Message Logger Sample” (nvdwx_html/dwx_canbus_logger_sample.html) states:

“On DRIVE PX 2, the CAN connectors marked with CAN-1…CAN-4 are reachable throught Aurix by the Tegras. For this to work, a proper setup of the Aurix needs to be made prior to running the application. Please refer to the EasyCAN user guide provided as part of PDK documentation to set up Aurix to filter and pass a selected subset of CAN messages.”

I can’t find the EasyCAN user guide referred to above. Could you please provide a link to where I can find/DL it?

Hello dnngbg,

Could you please see “Flashing and Using the Platform” -> “Flashing AURIX” part? Thanks.

For detailed information on flashing the AURIX firmware see the Elektrobit EB-DRIVE PX-BSL Users Guide for the EB TriLoad BootStrap Loader available in PDF format in the Elektrobit ZIP archive at:
/vibrante-t186ref-foundation/utils/scripts
• For DRIVE PX 2 AutoCruise, the run file is at:
vibrante-t186ref-foundation-4.1.4.0--p3407specific.run
• For DRIVE PX 2 AutoChauffeur, the run file is at:
/vibrante-t186ref-foundation-4.1.4.0--p2379specific.run

Hi,

I works on PX2 AutoChauffeur P2379 and try to test CAN-1 to CAN-4

after read DrivePX_StarterGuide-Aurix.pdf from 2016-12-15-DPX2-NV-V1.03

I not understand some place, could you explain more detail?

First Hardware test (page 5 of DrivePX_StarterGuide-Aurix.pdf)
Connect the V24-to USB adapter between Target and the Host <<< connect to CAN-1 ~ CAN-4 on Target?
Connect the Ethernet cable to the Target and to the Ethernet-to-USB-adapter on the Host <<< why need Ethernet-to-USB-adapter? Could I just connect my ethernet port on my PC?
Open a terminal program like PuTTy on the Host (115000 Bd, Serial) <<< 115000 is typo? 115200?

Is there any update on where that ‘EasyCAN’ user guide is? I wasn’t able to find it and under Flashing AURIX there is nothing related to CAN? I’m trying to get the vehicle CAN working with PX2 utilizing a .dbc file.

Do you try using CAN-5 on Tegra A with the driveworks samples? It works right out of the box.

Yeah I did, unfortunately I get a huge load of “invalid index” errors with the CAN-interpreter sample when using CAN 5 with a .dbc file that works perfectly on any other device. So I wanted to try a different way of connecting to the CAN.

Is the problem with can or the interpreter? You can just look at the raw data on Tegra A using candump. Or I think there is a driveworks sample that also just prints out data and doesn’t use a dbc.

Hey everyone,

is there any solution to get the sample_canbus_logger running with the can.aurix device (CAN1-CAN4)? CAN5 and CAN6 are working quite well as can.socket.

I copied a modified EasyCanConfigFile.conf (like mentioned in the EasyCAN user guide) to /etc/eb and tried the command:

nvidia@nvidia:~$ /usr/local/driveworks/bin/sample_canbus_logger --driver=can.aurix --params=ip=10.42.0.146,bus=a

.

The output is the following:

Program Arguments:
--driver=can.aurix
--filter=000:000
--hwtime=1
--params=ip=10.42.0.146,bus=a

Initialize DriveWorks SDK v0.3.422
Release build with GNU 4.9.2 from v0.3.1-rc2-0-g0475f26 against PDK v4.1.6.3
SDK: Resources mounted from /usr/local/driveworks-0.3/data/resources
SDK: Create NvMediaDevice
egl::Display: found 2 EGL devices
egl::Display: use drm device: drm-nvdc
SDK: dGPU has been detected as device number 0
SDK: iGPU has been detected as device number 1
SDK: Default GPU Device set to device number 0
SAL: identified board as DrivePX2-TegraA
SensorFactory::createSensor() -> can.aurix, ip=10.42.0.146,bus=a
Cannot setup CAN message filters: DW_NOT_IMPLEMENTED
EndpointUDP: started 10.42.0.146:50000
EndpointUDP: stopped 10.42.0.146:50000
SDK: Release NvMediaDevice
Driveworks SDK released

I can’t get any useful information from the output. Am I missing here something?

Dear pd_lab,

Could you try to run the app with below option? Thanks.
./sample_canbus_logger --driver=can.socket --params=device=can0

Hey SteveNV,

thanks for your response. I tried it and I’m receiving CAN messages (on Tegra A CAN-5). Nevertheless, the problem I have is not related to the can.socket drivers - these are working just fine. I’ve got troubles setting up the CAN adapters, which are connected to the AURIX MCU (can.aurix). All I get from the output (last post) is the following

Cannot setup CAN message filters: DW_NOT_IMPLEMENTED

but that doesn’t lead me anywhere.

Regards
pd_lab

Dear SteveNV,

is the source code of the sample_canbus_logger somewhere available?
Thanks!

Hi SteveNV,

where can i get the ZIP archive:DPX-EB-Tegra-X.XX-ready2compile.tar.gz ?

Thanks!

Dear hfliu,

DPX2-P2379-EB-V4.02.02_release.zip file is in DriveSDK/drive-t186ref-foundation/utils/scripts on hostPC. Thanks.

Dear SteveNV,

I can only find the binary-file LINUX_LXTHREADSX86_DrivePxApp.elf in DPX2-P2379-EB-V4.02.02_release directory ,I can not find it’s source code archive:DPX-EB-Tegra-X.XX-ready2compile.tar.gz.

Thanks.

Dear hfliu,

May I know where “DPX-EB-Tegra-X.XX-ready2compile.tar.gz” file came from? Thanks.

Dear SteveNV,
DPX-EB-Tegra-X.XX-ready2compile.tar.gz is mentioned in the file “EB-DrivePX_Software_User_Guide_DPX2.pdf”. Thanks.

Hi,

I am also facing the same problem when I tried to run ./sample_canbus_logger --driver=can.aurix --params=ip=10.42.0.146,bus=a

Error :
SAL: identified board as DrivePX2-TegraA
SensorFactory::createSensor() -> can.aurix, ip=10.42.0.146,bus=a
Cannot setup CAN message filters: DW_NOT_IMPLEMENTED
EndpointUDP: started 10.42.0.146:50000

But ./sample_canbus_logger --driver=can.socket --params=device=can0 is working. In my application I have to use two CAN channels So I have to use aurix driver.

How to solve this issue? I am using Aurix version DPX2-P2379-EB-Aurix-2.02.04

Thanks,
SUdhakar

hey some people mentioned here that we can access can 5 and 6 without Aurix. How can we setup the two can ports? Any help will be appreciated.Thanks

This file does not seem to exist in driveworks 5.0.5.0bL? I just did a fresh install for a host computer and I cannot find this executable anywhere.

I found the folder…I was looking in ‘drive-t186ref-foundation_src’ instead of ‘drive-t186ref_foundation’

Where is the location of this pdf? I cannot find it online, nor can I find it in my Driveworks installation.