Can't read data from can.aurix

Hi,

I tried to run the sample_canbus_logger to receive data from aurix can with the command:

./sample_canbus_logger --driver=can.aurix --params=ip=10.42.0.146,bus=a

Program Arguments:
–driver=can.aurix
–filter=000:000
–offscreen=0
–params=ip=10.42.0.146,bport=50000,bus=a,config-file=…/data/samples/sensors/can/EasyCanConfigFile.conf
–profiling=1
–send_i_understand_implications=0
–send_id=6FF

[05-02-2020 10:53:13] Platform: Detected DDPX - Tegra A
[05-02-2020 10:53:13] Initialize DriveWorks SDK v2.0.2081
[05-02-2020 10:53:13] Release build with GNU 4.9.4 from heads/buildbrain-branch-0-g36b127f against Drive PDK v5.1.0.2
[05-02-2020 10:53:13] TimeSource: monotonic epoch time offset is 1580927490189033
[05-02-2020 10:53:13] PTP Time is available from NVPPS Driver
[05-02-2020 10:53:14] Platform: number of GPU devices detected 1
[05-02-2020 10:53:14] Platform: currently selected GPU device integrated ID 0
[05-02-2020 10:53:14] SDK: Resources mounted from /usr/local/driveworks-2.0/data/
[05-02-2020 10:53:14] SDK: Create NvMediaDevice
[05-02-2020 10:53:14] egl::Display: found 1 EGL devices
[05-02-2020 10:53:14] egl::Display: use drm device: drm-nvdc
[05-02-2020 10:53:14] SensorFactory::createSensor() -> can.aurix, ip=10.42.0.146,bport=50000,bus=a,config-file=…/data/samples/sensors/can/EasyCanConfigFile.conf
Cannot setup CAN message filters: DW_NOT_SUPPORTED
[05-02-2020 10:53:14] EndpointUDP: started 10.42.0.146:50000

and it stuck at this point without receiving any data. The can logger sample worked fine with can.socket and can.virtual though.

I also tried to run the easycan_test binary under /home/nvidia/drive=t186ref-linux/samples/easycan and it showed:

not support model
model = e3550_t194a

I did try out the python aurix_tegra_a_can_send_receive.py script mentioned in the user guide and it didn’t either.

Thanks!

Hi shyam.sundar,

Recently other developer successfully ran sample_canbus_logger with aurix CAN on DRIVE Software 10.0. Please refer to https://devtalk.nvidia.com/default/topic/1070837/general/aurix-can-setup-in-cpp-file/ .

Which CAN connector are you using for aurix CAN? Could you try with DRIVE Software 10.0? Maybe your can send him a private message for his experience.
(from https://developer.nvidia.com/DRIVE/secure/docs/DRIVE_Mech_Inst_Guide_DI-08957-001_v07.pdf)

Hey Vick,
Thanks for the quick response. We are using DRIVE Software 9.0 is easyCAN supported on 9.0?

It should be working. The developer using DRIVE Software 9.0 could run sample_canbus_logger with aurix CAN. FYI.

https://devtalk.nvidia.com/default/topic/1065646/general/recording-issue-about-can-messages-through-aurix/post/5404361/#5404361