Activating Wake-On-Lan for ConnectX-3 MCX311A-XCAT

I was wondering if there is a way to enable WOL for the MCX311A-XCAT HCA? Right now I’m using the builtin Linux driver and ethtool only shows d as available WOL option. Do I need to use the mlnx_en driver to activate WOL?

Hello Lennart,

Thank you for posting your inquiry on the NVIDIA Networking Community.

Please the instructions provide through the following link to enable WOL on the ConnectX-3 → https://docs.nvidia.com/networking/display/MFTv4140/MFT+Supported+Configurations+and+Parameters

The table shows the configurable parameter → WOL_MAGIC_EN_P1/P2

Install the MFT tools from our website (https://network.nvidia.com/products/adapter-software/firmware-tools/) and use the ‘mlxconfig’ command to enable WOL on the ConnectX-3. → # mlxconfig -d mt4099_pci_cr0 set WOL_MAGIC_EN_P<port #>=1

After changing this setting please reboot the node to make the setting active.

Please make sure the adapter is running the latest f/w version available.

Thank you and regards,

~NVIDIA Networking Technical Support

So I just tested this, I ran mlxup to update the fw and got

sudo ./mlxup

Querying Mellanox devices firmware …

Device #1:


Device Type: ConnectX3

Part Number: MCX311A-XCA_Ax

Description: ConnectX-3 EN network interface card; 10GigE; single-port SFP+; PCIe3.0 x4 8GT/s; RoHS R6

PSID: MT_1170110023

PCI Device Name: 0000:07:00.0

Port1 MAC: …

Port2 MAC: …

Versions: Current Available

FW 2.42.5000 2.42.5000

PXE 3.4.0752 3.4.0752

Status: Up to date

So seems to be up to date. however when querying mlxconfig / mstconfig for the flag, it’s not listed and attempting to set the flag, I get

sudo mstconfig -d 07:00.0 set WOL_MAGIC_EN_P1=1 3 ↵

Device #1:


Device type: ConnectX3

Device: 07:00.0

Configurations: Next Boot New

-E- Device doesn’t support WOL_MAGIC_EN_P1 configuration

sudo mstconfig -d 07:00.0 q 3 ↵

Device #1:


Device type: ConnectX3

Device: 07:00.0

Configurations: Next Boot

SRIOV_EN False(0)

NUM_OF_VFS 0

LOG_BAR_SIZE 0

BOOT_OPTION_ROM_EN_P1 False(0)

BOOT_VLAN_EN_P1 False(0)

BOOT_RETRY_CNT_P1 0

LEGACY_BOOT_PROTOCOL_P1 None(0)

BOOT_VLAN_P1 0

BOOT_OPTION_ROM_EN_P2 False(0)

BOOT_VLAN_EN_P2 False(0)

BOOT_RETRY_CNT_P2 0

LEGACY_BOOT_PROTOCOL_P2 None(0)

BOOT_VLAN_P2 0

IP_VER_P1 IPv4(0)

IP_VER_P2 IPv4(0)

CQ_TIMESTAMP False(0)

mlxconfig just says that it can’t query the current device configuration. So I guess my card doesn’t support WOL?