Enabling Wake On Lan on ConnectX-3 Dual Port IBM

I’ve got a ConnectX-3 that I’ve flashed the latest Mellanox Firmware to from the Latest Lenovo firmware and successfully Installed the WinOF drivers. One issue is I’d like the setup Wake On lan i read in the WinOF release notes that latest version 5.50 WOL is not supported is their another way of configuring this like within the card firmware or will new drivers be support this?

Hi Jack,

Few notes regarding the Wake on LAN feature:

  • Regarding the driver side:

    • In the latest version of 5.50 there is no support for WOL feature .
    • In order to use it need to install 5.35
  • Regarding the MFT (Mellanox Firmware tools) side:

    • WOL feature is supported in MFT 4.9.
    • ​In the latest MFT versions 4.10/4.11 it’s not supported.

In order to use this feature need to install WinOF 5.35 and MFT 4.9



I’ve Uninstalled both WinOF and MFT and downgraded to 5.35 and 4.9 after doing so the driver doesn’t work at all “The Device cannot start” I’ve reinstalled WinOF and MFT still didn’t fix it the newer WinOF that doesn’t support WOL did work before downgrading.SettingToError


Hi Jack,

Such issue can occur during downgrade procedure.

Please Try the following :

  1. First try to roll back the driver and reboot the server.

If it’s not working :

  1. Remove both driver and the Mellanox adapters from the device manager.

3 Reboot the server.

  1. Make sure that the system identify the Adapters.

  2. Reinstall the 5.35 driver from the following site:


Note : Make sure it’s compatible with the OS.

  1. Make sure that the firmware for ConntectX-3 is 2.40.5032 or above.

Let me know if it’s working.



Issue persists after trying the steps you suggested, I also tried a fresh install of Windows on another drive same issue. I confirmed that my firmware is updated to 2.42.5000 on the card.

Hi Jack,

Since the issue still persist and for deep debug of the issue

I suggest to open a ticket at support@mellanox.com.



I currently don’t have a support plan could you atleast let me know if its hardware that is the issue that doesn’t support wake on lan since its an OEM card? I believe it is as i run the command mlxconfig -d mt4099_pci_cr0 set WOL_MAGIC_EN_P1=1 and get

Device #1:

Device type: ConnectX3

Device: mt4099_pci_cr0

Configurations: Next Boot New

-E- Device doesn’t support WOL_MAGIC_EN_P1 configuration.

Hi Jack,

It’s correct the current OEM adapter that you are using doesn’t support the WOL feature.