Add ULMB option to nvidia-settings

Hello!

In windows I can switch between G-SYNC and ULMB, but in linux there is only an “Allow G-SYNC” option.

Greets

+1

Enhancement tracking id : 200191384

Almost one year has been passed after aemkei’s request. How long do we need to get such an essential function? Is it really so hard to just added one option? Or just because you guys intend to ignore the need for Linux users. So disappointment about your guys.

Nice, finally! Got it working using:

nvidia-settings -a currentmetamode=“nvidia-auto-select { AllowGSYNC=Off }”

https://devtalk.nvidia.com/default/topic/999899/cannot-enable-ulmb

If anyone is wondering why this isn’t working, I got my ULMB working using this code -> nvidia-settings -a CurrentMetaMode=“2560x1440_85 { AllowGSYNC=Off }” <-. Mine would not work because currentmetamode was case sensitive and would only work with the capitalized version. Please note you will want to put in your own resolution and Hz.

Cheers!

Bryce

Hi all,
Arch linux latest, nvidia drivers 440.82 Linux server 5.6.7-arch1-1-vfio. Asus Rog PG278Q 2K 144hz. RTX2070Strix.
just an update. Add a second line of “metamodes” in the xorg.conf , give a black screen. (with or without uppercase letters)

Option "MetaModes" "2560x1440_120 { AllowGSYNC=Off }"

Also digit this command report nothing:
sudo nvidia-settings -a CurrentMetaMode=“2560x1440_120 { AllowGSYNC=Off }”

With or without reboot.

The only way it worked for me was add the meta to the existing one:

Section “Screen”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Stereo" "0"
Option         "nvidiaXineramaInfoOrder" "DFP-3"
Option         "metamodes" "DP-2: 2560x1440_120 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On, AllowGSYNC=Off}"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24
EndSubSection

In the ~.nvidia-settings-rc the gsync is set to zero and seems disabled. But , if I disable the G-Sync via root it save nothing in the xorg.conf.
So seems something should be still refined.
I tried also checking the README section option BUT the G-Sync is even not mentioned at all.
http://us.download.nvidia.com/XFree86/Linux-x86_64/440.82/README/

ps:
this panel (asus) is really bad for work (for gaming is fine , but for text reading make you eyes blow away). And enabling the ULMB make the things even worse , but was worth a try. Never mind switched back the standard OD option.