adv7282-m fails to get detected by i2cdetect but i2cget/i2cset works


I am trying to hook up an analogue camera to the jetson using the adv7282-m. I have tried to connect the chip to i2c2 and i2c3 but when I execute i2cdetect nothing gets detected. If i use i2cset to set the value of the register and then retrive it using i2cget it works. I am using an evaluation board for the adv7282-m so hardware error is probably not an issue. GEN2_I2C is at 3.3V and CAM_I2C is at 1.8. Any ideas of what might be wrong. Thanks in advance.

Try to run the i2cdetect command with the options -r and -a. The ‘-r’ option can detect more devices on the i2cbus as far as I have tested. The ‘-a’ option allows for probing all possible i2c chip addresses. Also make sure you are probing the correct i2cbus. Use ‘-l’ option to display all the i2cbuses available for probing. Another reason could be root permissions for i2cdetct command.


it is bug. There are several write commands that also fail on the adv7282m when connected to the jetson. All other devices I have tried so far work fine.


are you able to detect any devices on jetson on i2c2 or i2c3 without adv7282-m? I suspect bus is somehow locked by adv7282-m.

Or the other case is adv7282-m is not power on.


Have your adv7282m and driver program worked well?


Have your adv7282m and driver program worked well? I have the same design.

Have you succesfully make the adv7282m work?

My adv7282m I2C is Ok,but can not capture image.Where can I get some reference materials about adv7282m on TK1? Thank you!

You need run clock signal on clock camera pin, it’s 24MHz, after that you can see a module on i2c bus.