An error has occurred. See the log file .../.eclipse/org.eclipse.platform_4.4.1_1112099189_linux_gtk_x86_64/configuration/1583865584917.log.

Error occurres when starting Nvidia Visual Profiler. Log file:

!SESSION 2020-03-10 19:31:37.500 -----------------------------------------------
eclipse.buildId=unknown
java.version=11.0.6
java.vendor=Ubuntu
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64 -data @noDefault

!ENTRY com.nvidia.cuda.ide.editor 4 0 2020-03-10 19:31:37.928
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.nvidia.cuda.ide.editor [6]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.ui; bundle-version="[5.8.0.nvidia,5.8.1)"
-> Bundle-SymbolicName: org.eclipse.cdt.ui; bundle-version=“5.8.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.ui [71]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.core; bundle-version="[5.2.0,6.0.0)"
-> Bundle-SymbolicName: org.eclipse.cdt.core; bundle-version=“5.7.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.core [69]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY com.nvidia.pgprof.application 4 0 2020-03-10 19:31:37.931
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.nvidia.pgprof.application [10]
Unresolved requirement: Require-Bundle: com.nvidia.viper
-> Bundle-SymbolicName: com.nvidia.viper; bundle-version=“10.2.0.201910240259”; singleton:=“true”
com.nvidia.viper [12]
Unresolved requirement: Require-Bundle: com.nvidia.cuda.ide.editor; bundle-version=“10.2.0”
-> Bundle-SymbolicName: com.nvidia.cuda.ide.editor; bundle-version=“10.2.0.201910240259”; singleton:=“true”
com.nvidia.cuda.ide.editor [6]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.ui; bundle-version="[5.8.0.nvidia,5.8.1)"
-> Bundle-SymbolicName: org.eclipse.cdt.ui; bundle-version=“5.8.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.ui [71]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.core; bundle-version="[5.2.0,6.0.0)"
-> Bundle-SymbolicName: org.eclipse.cdt.core; bundle-version=“5.7.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.core [69]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY com.nvidia.viper 4 0 2020-03-10 19:31:37.934
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.nvidia.viper [12]
Unresolved requirement: Require-Bundle: com.nvidia.cuda.ide.editor; bundle-version=“10.2.0”
-> Bundle-SymbolicName: com.nvidia.cuda.ide.editor; bundle-version=“10.2.0.201910240259”; singleton:=“true”
com.nvidia.cuda.ide.editor [6]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.ui; bundle-version="[5.8.0.nvidia,5.8.1)"
-> Bundle-SymbolicName: org.eclipse.cdt.ui; bundle-version=“5.8.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.ui [71]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.core; bundle-version="[5.2.0,6.0.0)"
-> Bundle-SymbolicName: org.eclipse.cdt.core; bundle-version=“5.7.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.core [69]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY com.nvidia.viper.application 4 0 2020-03-10 19:31:37.937
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.nvidia.viper.application [13]
Unresolved requirement: Require-Bundle: com.nvidia.viper; bundle-version=“10.2.0”
-> Bundle-SymbolicName: com.nvidia.viper; bundle-version=“10.2.0.201910240259”; singleton:=“true”
com.nvidia.viper [12]
Unresolved requirement: Require-Bundle: com.nvidia.cuda.ide.editor; bundle-version=“10.2.0”
-> Bundle-SymbolicName: com.nvidia.cuda.ide.editor; bundle-version=“10.2.0.201910240259”; singleton:=“true”
com.nvidia.cuda.ide.editor [6]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.ui; bundle-version="[5.8.0.nvidia,5.8.1)"
-> Bundle-SymbolicName: org.eclipse.cdt.ui; bundle-version=“5.8.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.ui [71]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.core; bundle-version="[5.2.0,6.0.0)"
-> Bundle-SymbolicName: org.eclipse.cdt.core; bundle-version=“5.7.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.core [69]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY com.nvidia.viper.birt 4 0 2020-03-10 19:31:37.939
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.nvidia.viper.birt [14]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.cdt.core 4 0 2020-03-10 19:31:37.942
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.cdt.core [69]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.cdt.ui 4 0 2020-03-10 19:31:37.944
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.cdt.ui [71]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.core; bundle-version="[5.2.0,6.0.0)"
-> Bundle-SymbolicName: org.eclipse.cdt.core; bundle-version=“5.7.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.core [69]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY com.nvidia.viper.birt 2 0 2020-03-10 19:31:38.645
!MESSAGE Could not resolve module: com.nvidia.viper.birt [14]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

!ENTRY com.nvidia.cuda.ide.editor 2 0 2020-03-10 19:31:38.646
!MESSAGE Could not resolve module: com.nvidia.cuda.ide.editor [6]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.ui; bundle-version="[5.8.0.nvidia,5.8.1)"
-> Bundle-SymbolicName: org.eclipse.cdt.ui; bundle-version=“5.8.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.ui [71]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.core; bundle-version="[5.2.0,6.0.0)"
-> Bundle-SymbolicName: org.eclipse.cdt.core; bundle-version=“5.7.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.core [69]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

!ENTRY org.eclipse.core.filesystem.java7 2 0 2020-03-10 19:31:38.646
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.java7 [84]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
Unresolved requirement: Fragment-Host: org.eclipse.core.filesystem; bundle-version="[1.4.100,2.0.0)"

!ENTRY com.nvidia.pgprof.application 2 0 2020-03-10 19:31:38.646
!MESSAGE Could not resolve module: com.nvidia.pgprof.application [10]
Unresolved requirement: Require-Bundle: com.nvidia.viper
-> Bundle-SymbolicName: com.nvidia.viper; bundle-version=“10.2.0.201910240259”; singleton:=“true”
com.nvidia.viper [12]
Unresolved requirement: Require-Bundle: com.nvidia.cuda.ide.editor; bundle-version=“10.2.0”
-> Bundle-SymbolicName: com.nvidia.cuda.ide.editor; bundle-version=“10.2.0.201910240259”; singleton:=“true”
com.nvidia.cuda.ide.editor [6]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.ui; bundle-version="[5.8.0.nvidia,5.8.1)"
-> Bundle-SymbolicName: org.eclipse.cdt.ui; bundle-version=“5.8.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.ui [71]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.core; bundle-version="[5.2.0,6.0.0)"
-> Bundle-SymbolicName: org.eclipse.cdt.core; bundle-version=“5.7.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.core [69]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

!ENTRY com.nvidia.viper.application 2 0 2020-03-10 19:31:38.646
!MESSAGE Could not resolve module: com.nvidia.viper.application [13]
Unresolved requirement: Require-Bundle: com.nvidia.viper; bundle-version=“10.2.0”
-> Bundle-SymbolicName: com.nvidia.viper; bundle-version=“10.2.0.201910240259”; singleton:=“true”
com.nvidia.viper [12]
Unresolved requirement: Require-Bundle: com.nvidia.cuda.ide.editor; bundle-version=“10.2.0”
-> Bundle-SymbolicName: com.nvidia.cuda.ide.editor; bundle-version=“10.2.0.201910240259”; singleton:=“true”
com.nvidia.cuda.ide.editor [6]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.ui; bundle-version="[5.8.0.nvidia,5.8.1)"
-> Bundle-SymbolicName: org.eclipse.cdt.ui; bundle-version=“5.8.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.ui [71]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.core; bundle-version="[5.2.0,6.0.0)"
-> Bundle-SymbolicName: org.eclipse.cdt.core; bundle-version=“5.7.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.core [69]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

!ENTRY org.eclipse.cdt.core 2 0 2020-03-10 19:31:38.646
!MESSAGE Could not resolve module: org.eclipse.cdt.core [69]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

!ENTRY com.nvidia.viper 2 0 2020-03-10 19:31:38.646
!MESSAGE Could not resolve module: com.nvidia.viper [12]
Unresolved requirement: Require-Bundle: com.nvidia.cuda.ide.editor; bundle-version=“10.2.0”
-> Bundle-SymbolicName: com.nvidia.cuda.ide.editor; bundle-version=“10.2.0.201910240259”; singleton:=“true”
com.nvidia.cuda.ide.editor [6]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.ui; bundle-version="[5.8.0.nvidia,5.8.1)"
-> Bundle-SymbolicName: org.eclipse.cdt.ui; bundle-version=“5.8.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.ui [71]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.core; bundle-version="[5.2.0,6.0.0)"
-> Bundle-SymbolicName: org.eclipse.cdt.core; bundle-version=“5.7.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.core [69]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

!ENTRY org.eclipse.cdt.ui 2 0 2020-03-10 19:31:38.647
!MESSAGE Could not resolve module: org.eclipse.cdt.ui [71]
Unresolved requirement: Require-Bundle: org.eclipse.cdt.core; bundle-version="[5.2.0,6.0.0)"
-> Bundle-SymbolicName: org.eclipse.cdt.core; bundle-version=“5.7.0.nvidia-qualifier”; singleton:=“true”
org.eclipse.cdt.core [69]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

!ENTRY org.eclipse.osgi 4 0 2020-03-10 19:31:38.647
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application “com.nvidia.viper.application.application” could not be found in the registry. The applications available are: org.eclipse.ant.core.antRunner, org.eclipse.birt.report.engine.ReportExecutor, org.eclipse.e4.ui.workbench.swt.E4Application, org.eclipse.e4.ui.workbench.swt.GenTopic, org.eclipse.equinox.app.error, org.eclipse.equinox.p2.director, org.eclipse.equinox.p2.garbagecollector.application, org.eclipse.equinox.p2.publisher.InstallPublisher, org.eclipse.equinox.p2.publisher.EclipseGenerator, org.eclipse.equinox.p2.publisher.ProductPublisher, org.eclipse.equinox.p2.publisher.FeaturesAndBundlesPublisher, org.eclipse.equinox.p2.reconciler.application, org.eclipse.equinox.p2.repository.repo2runnable, org.eclipse.equinox.p2.repository.metadataverifier, org.eclipse.equinox.p2.artifact.repository.mirrorApplication, org.eclipse.equinox.p2.metadata.repository.mirrorApplication, org.eclipse.equinox.p2.updatesite.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.CategoryPublisher, org.eclipse.help.base.infocenterApplication, org.eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool, org.eclipse.ui.ide.workbench.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:566)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
at org.eclipse.equinox.launcher.Main.main(Main.java:1438)

Hi,

Can you please provide more details like,

  1. CUDA toolkit version, you can find it by running below command

    /usr/local/cuda/bin/nvcc --version

  2. OS/Platform version
  3. Java versions installed on your machine


Thanks,
Ramesh

So this error was on my stationary computer at home, but i have the same issue with my Macbook Pro:

Cuda toolkit version:
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2019 NVIDIA Corporation
Built on Wed_Oct_23_19:24:38_PDT_2019
Cuda compilation tools, release 10.2, V10.2.89

OS:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION=“Ubuntu 18.04.4 LTS”

Java Version(1):
There is only one alternative in link group java (providing /usr/bin/java): /usr/lib/jvm/java-11-openjdk-amd64/bin/java
Nothing to configure.

Thanks for the details.

There are some known issues when running Visual Profiler on Ubuntu 18.

To run Visual Profiler on Ubuntu 18, make sure that you installed JRE 1.8 (Java 8) and you invoke Visual Profiler with the command-line option as below:

nvvp -vm /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java

Note that the -vm option is only required when JRE is not included in CUDA Toolkit package and JRE 1.8 is not in the default path.

For more information please check:
https://docs.nvidia.com/cuda/profiler-users-guide/index.html#visual

1 Like

Thanks! How ever, i am unable to run Nvidia Visual Profiler 10.2(That comes with Cuda Toolkit) using nvvp. Do you have a fix for this as well?

Hi,

Do you run into other issue after resolving the JRE issue? Can you please provide more details and the error log?

Ubuntu 20.04
CUDA 11.1.1
nvvp 10.1 and 11.1 (see below)

root@ctm:~# /usr/local/cuda/bin/nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2020 NVIDIA Corporation
Built on Mon_Oct_12_20:09:46_PDT_2020
Cuda compilation tools, release 11.1, V11.1.105
Build cuda_11.1.TC455_06.29190527_0

Starting nvvp from Desktop, I get the eclipse error in OP.

An error has occurred. See the log file
/home/geohei/.eclipse/org.eclipse.platform_4.4.1_1101596085_linux_gtk_x86_64/configuration/1604505407634.log.

Starting from console (just nvvp) works fine, but it’s nvvp is version 10.1!

I installed cuda 11.1.1 initially. Why do I have 2 versions of nvvp?
How can I make the Desktop version (11.1) run without error from Desktop?

Thanks,