Cannot launch NVidia Visual Profiler

Today i installed CUDA 8. When i run Visual Profiler, i can see its logo displaying for a moment but then it suddenly stops. I tried launching as admin, same results. What is wrong? Platform: Windows 8.1 x86_64 Thanks in advance.

Hi, CobraL0rd

Please try launch from command line ‘nvvp’ or click nvvp.exe in C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0\libnvvp\ to see if it can work or any error reported.

If still not work, please uninstall and re-install the toolkit, try again.

If all this not work for you, please tell me the toolkit version and driver info.
I will try my side.

Thanks !

Nothing worked. I even updated my GPU drivers. Didn’t work.

It is nVidia CUDA 8. GPU Driver info?

Version is 21.21.13.7866

deviceQuery log below:

deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: “GeForce GTX 660”
CUDA Driver Version / Runtime Version 8.0 / 8.0
CUDA Capability Major/Minor version number: 3.0
Total amount of global memory: 2048 MBytes (2147483648 bytes)
( 5) Multiprocessors x (192) CUDA Cores/MP: 960 CUDA Cores
GPU Clock rate: 1098 MHz (1.10 GHz)
Memory Clock rate: 3004 Mhz
Memory Bus Width: 192-bit
L2 Cache Size: 393216 bytes
Max Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536,65536), 3D=(4096,4096,4096)
Max Layered Texture Size (dim) x layers 1D=(16384) x 2048, 2D=(16384,16384) x 2048
Total amount of constant memory: 65536 bytes
Total amount of shared memory per block: 49152 bytes
Total number of registers available per block: 65536
Warp size: 32
Maximum number of threads per multiprocessor: 2048
Maximum number of threads per block: 1024
Maximum sizes of each dimension of a block: 1024 x 1024 x 64
Maximum sizes of each dimension of a grid: 2147483647 x 65535 x 65535
Maximum memory pitch: 2147483647 bytes
Texture alignment: 512 bytes
Concurrent copy and kernel execution: Yes with 1 copy engine(s)
Run time limit on kernels: Yes
Integrated GPU sharing Host Memory: No
Support host page-locked memory mapping: Yes
Alignment requirement for Surfaces: Yes
Device has ECC support: Disabled
CUDA Device Driver Mode (TCC or WDDM): WDDM (Windows Display Driver Model)
Device supports Unified Addressing (UVA): No
Device PCI Bus ID / PCI location ID: 1 / 0
Compute Mode:
< Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 8.0, CUDA Runtime Version = 8.0, NumDevs = 1, Device0 = GeForce GTX 660

Hi,

I use cuda 8.0.61 downloaded from https://developer.nvidia.com/cuda-downloads and can not reproduce the issue. The driver version in the toolkit is 367.51.

Please tell me your toolkit and driver version.

You can query toolkit version by enter C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0\bin, and execute “nvprof.exe --version”

driver version can be got by enter C:\Program Files\NVIDIA Corportation\NVSMI, and execute ‘nvidia-smi.exe’

Too bad, because i just cannot launch the C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0\libnvvp\nvvp.exe . When i run it, the logo appears for about 3 seconds and then closes.

Driver version (as reported by Device Manager): 21.21.13.7866

NVSMI log

Mon Mar 06 16:31:33 2017
±----------------------------------------------------------------------------+
| NVIDIA-SMI 378.66 Driver Version: 378.66 |
|-------------------------------±---------------------±---------------------+
| GPU Name TCC/WDDM | Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 660 WDDM | 0000:01:00.0 N/A | N/A |
| 30% 33C P8 N/A / N/A | 292MiB / 2048MiB | N/A Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 Not Supported |
±----------------------------------------------------------------------------+

Nvprof log:

nvprof: NVIDIA ® Cuda command line profiler
Copyright © 2012 - 2016 NVIDIA Corporation
Release version 8.0.61 (21)

Hi,

Sorry, I still can not reproduce the issue with the exact toolkit and driver.

Very strange. I haven’t restricted the program in any way either. I just checked.

How does one (for example you) is supposed to launch this program. I just click the program name to launch it. I don’t have anything else open. Maybe safe mode will work (or maybe not, because the display driver isn’t operating at the time)? What else can i try?

Usually, I will type ‘nvvp’ in command console to launch the applicaton.
But that’s not the point I think, as click the program name should also work.

Hi CobraLOrd,

Did you ever get the nvvp to work?

I am having the same problems you have/had. When I type ‘nvvp’ at
the (Linux) command line I can see the nvvp logo but then nothing
happens.

Have you been able to sort this out?

Thanks!

jusini

Hi jusini.

This occurred to me on Windows. On Ubuntu it works fine. I was never able to fix this problem though.

It just didn’t work. Let me know if you find out a way to solve it.

Good luck.

Hi,CobraL0rd

We never met this issue before. But just now we reproduce this on WIN7 randomly on specific machine.
We’ll have dev check ASAP.
Anything update, I will let you know.

Best Regards
Vera

Hi, CobraLOrd

We have figured the reason but not sure if you are face the same problem.

Would you please check the file under C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0\libnvvp to see if there are various version jar ? Maybe you can just paste the folder details here.

Thanks in advance.

No there is no .jar file in this directory. But your post sprout my curiosity and i got some ideas. So i checked the file nvvp.ini in there. I noticed that it was launching nvvp / eclipse using …\jre\bin\javaw.exe. So i changed that to …\jre\bin\java.exe. And it worked! Visual Profiler works perfectly now.

I don’t remember what i might have done in the past with java / Eclipse’s console window features, and i actually don’t believe i did anything to justify this. I just did it out of some intuition i had. Why would a console app launch and not a window app? This is the only change between java and javaw afaik. Anyway, if anybody has an idea let me know.

Hopefully this may help someone else too. Cheers.

Glad to see the problem solved on your side.

Best Regards
Vera

Hi, I am using Ubuntu and I got the same thing. I tried running org.eclipse.osgi_3.10.1.v20140901633.jar directly. Running success but still nothing showing up.

Please check /usr/local/cuda/libnvvp/nvvp.ini to make sure the java path is correct

I face the same problem. Upon calling nvvp from the command line, the splash screen pops up and after it vanishes I get an unspecific error message “An error has occurred.” with a reference to a log file (content see below):

$ nvvp /tmp/timeline.nvvp

(java:1951): Gtk-WARNING **: 12:38:31.252: Unable to locate theme engine in module_path: "adwaita",

(java:1951): Gtk-WARNING **: 12:38:31.261: Unable to locate theme engine in module_path: "adwaita",
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.eclipse.osgi.storage.FrameworkExtensionInstaller (file:/usr/local/cuda-10.0/libnvvp/plugins/org.eclipse.osgi_3.10.1.v20140909-1633.jar) to method java.net.URLClassLoader.addURL(java.net.URL)
WARNING: Please consider reporting this to the maintainers of org.eclipse.osgi.storage.FrameworkExtensionInstaller
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

(nvvp:1950): Gtk-WARNING **: 12:38:33.787: Unable to locate theme engine in module_path: "adwaita",

(nvvp:1950): Gtk-WARNING **: 12:38:33.792: Unable to locate theme engine in module_path: "adwaita",

$ cat $HOME/.eclipse/org.eclipse.platform_4.4.1_1792157559_linux_gtk_x86_64/configuration/1558521511409.log
!ENTRY org.eclipse.osgi 4 0 2019-05-22 12:38:33.552
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "com.nvidia.viper.application.application" could not be found in the registry. The applications available are: org.eclipse.ant.core.antRunner, org.eclipse.birt.report.engine.ReportExecutor, org.eclipse.e4.ui.workbench.swt.E4Application, org.eclipse.e4.ui.workbench.swt.GenTopic, org.eclipse.equinox.app.error, org.eclipse.equinox.p2.director, org.eclipse.equinox.p2.garbagecollector.application, org.eclipse.equinox.p2.publisher.InstallPublisher, org.eclipse.equinox.p2.publisher.EclipseGenerator, org.eclipse.equinox.p2.publisher.ProductPublisher, org.eclipse.equinox.p2.publisher.FeaturesAndBundlesPublisher, org.eclipse.equinox.p2.reconciler.application, org.eclipse.equinox.p2.repository.repo2runnable, org.eclipse.equinox.p2.repository.metadataverifier, org.eclipse.equinox.p2.artifact.repository.mirrorApplication, org.eclipse.equinox.p2.metadata.repository.mirrorApplication, org.eclipse.equinox.p2.updatesite.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.CategoryPublisher, org.eclipse.help.base.infocenterApplication, org.eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool, org.eclipse.ui.ide.workbench.
        at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
        at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:566)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1438)

$ cat /usr/local/cuda-10.0/libnvvp/nvvp.ini
-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20140603-1326
-data
@noDefault

Hi,

From the log it seems you are running nvvp from CUDA 10.0. Can you please tell which OS you are running on? Note that you need few extra steps on some OSs. For more details check below link.

https://docs.nvidia.com/cuda/profiler-users-guide/index.html#visual


Thanks,
Ramesh

I am running on Ubuntu 18.04.2 LTS. After installing openjdk-8-jre the profiler now works if I start it with

nvvp -vm /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java /tmp/timeline.nvvp

Thanks.

Good to hear that it worked for you.


Thanks,
Ramesh