An exception occurred when using the USB to serial port solution(XR21V1410) in Orin NX

My environment is :
35.3.1 BSP
Orin NX 8GB module and customized carried board.
There is an USB to serial port solution XR1410 on our board.
And we found an error:
The first time opening XR COM port test is normal, the second time opening COM port only allows sending, not receiving

Hardware path is Orin NX usb resource → FE1.1 USB hub → XR1410

hardware design picture is here:
XR4V410 原理图.zip (175.7 KB)

Can anyone help me solve this problem?

Furthermore, I have conducted the following verification:

1.Under the same 35.3.1 SDK and hardware, when switching to the Xavier NX SOM, the XR serial port works properly, but Orin NANO has the same error.

2.When we use a external module XR1414 on Orin NX original usb resource, the XR serial port works fine, too.(driver is the same as XR1410)

So based on the above verification, I conclude that the issue maybe related to the Orin SOM.

This looks like your USB HUB issue.

Hi, Trumany,
But the same SDK and carried board + Xavier NX SOM , there is no issue.

To make sure if the reason is not related to our USB HUB(FE1.1):
I tested two external USB hubs, and connected a XR1414 module to each of them, based on the following Orin NX original USB resourse , and XR serial test result became failed.

Please check it, thank you for help!

It really looks like compatible issue. From Orin side, your circuit design is fine, and the USB driver should be no problem since it can work well with XR1414 module (you can try other USB devices too). I don’t see other clue that need to tune from Orin side.

This is also a confusing point for me.
The same hardware and software, work fine with Xavier NX, but fail with Orin NX.

I add a PCIE-TO-USB-HUB chip (VL817), and then connect XR1414,the same error happend with Orin NX SOM.

Maybe we should try to find the differnt between these two SOM in SDK?
Or can you test a USB-TO-SERIAL module in your environment?

The same hardware and software

請問這個是什麼意思? devicetree本身在Xavier跟Orin就不會一樣. 你所謂的software一樣是?

還有你的zip file看起來沒辦法解壓, 不知道能否重新上傳一下

另外你要不要直接把這個所謂的XR1410放在Orin Nano devkit上面驗證一樣?

“The same hardware and software”指的是:相同的底板硬件和SDK版本,我们知道两个核心板在内核内有区别,因此也怀疑是否是这一块的差异导致问题出现。

XR4V410 原理图.zip (175.4 KB)

好的,我下一步计划用3509 devkit底板+Orin NX进行验证


我這邊點開新的zip file裡面有三份jpg. 但你上面這個 USBSS_TX/RX接出來的東西在你這三份jpg我沒有看到


两种usb资源原理图.zip (250.9 KB)

Hi, XR14V10 is USB2.0 design, the “original usb resource” is USBSS design…what do you want to prove?

Perhaps I need to summarize our above test results:
With the same hardware and the same 35.3.1 SDK,
Orin NX result is :
original USB 2.0 → USB HUB → XR1410 ,Serial Port Test Failed
original USB 3.0 → XR1414 , Serial Port Test Successful
original USB 3.0 → external USB HUB device → XR1414 ,Serial Port Test Failed.

However, under these conditions, Xavier NX all test success.

So we have reason to suspect that the issue may be related to the SOM.

我請教一個問題… 你在改這些硬體的時候你的device tree有跟著改動嗎?

另外 我们验证了 3509底板+ 5.1.1 devkit + Orin NX,并接入外接的XR1414模块,串口测试也有一样的异常;
相同的 3509底板 +5.1.1 devkit + Xavier NX, 接入外接的XR1414模块,串口测试正常。

我们没有改动device tree ,当前OrinNX与XavierNX的测试结果,系统都是基于sdkmanager烧录的5.1.1 系统。

能請你用jp5.1.2 + Orin Nano devkit做測試嗎 ? USB firmware 在這版本有更新
如果依然失敗的話請你提供dmesg. 請不要一直說 有異常有異常但是給不出log.

既然devkit看起來有機會複製到, 我這邊就先不管你們板子的情況了.

好的,其实是因为dmesg在正常/异常情况下 log均没有差异 所以我们没有提交log给你们,

請注意一下我這裡的重點其實是Orin Nano devkit. (不是3509)

我们目前还没有Orin Nano devkit的开发套件,请问能用3509+Orin Nano/NX 进行测试吗?