Android ADB USB driver failure

Hello all,

I’ve recently been trying to begin development on the Shield tablet from a Windows 7 system, and have run into some driver issues. I downloaded and installed the Nvidia Shield Tablet USB drivers from here and successfully got communications going between Android Studio and the tablet. However, after a reinstall of the Android SDK for unrelated reasons, the driver no longer worked.

Sure enough, the Shield tablet is now showing up as a “Portable Device” in Device Manager, not an Android device. Uninstalling and reinstalling the drivers doesn’t work either. If I automatically search for drivers, Windows installs the MTP USB standard drivers. Browsing for the correct driver using “Have Disk” gives me the “Folder specified doesn’t contain a compatible software driver” error. Fresh downloads of the Nvidia Shield Tablet and/or Shield Family drivers give the same result. It seems like Windows is refusing to acknowledge that the INF is correct for the Shield.

Android SDK has been reinstalled (again) to no avail. It works fine when using an emulator but in no way can I get it to work on my actual hardware.

Any thoughts would be appreciated.

Fixed. The drivers will not install if the Shield is currently configured to connect as an MTP media device (Settings -> Storage -> USB computer connection).