Apply the patch(pcie-regulator.patch) ,pcie x16 in devkit still not work

Flash jetpack5.0.1 into orin devkit ,but pcie X16 not work ,put pcie card into pcie X16 slot, used cmd lspci ,show nothing.apply pcie-regulator.patch to kernel ,still can not work.
attacment is uartlog after apply the patch and patch
uartlog.txt (28.1 KB)
pcie-regulator.patch (1.0 KB)

Hi,

Do you remember to copy the updated dtbo to the kernel/dtb?

HI
yes,I copy tegra234-p3701-0000-p3737-0000.dtb into kernel/dtb/ , dmesg | grep DTB ,time show update.

Do those two property show up in your /proc/device-tree?

Hi, which two property

Haven’t you read the patch by yourself before applying to your system?

Do you mean nvidia,refclk-select-gpios in pcie_ep@141a0000 and regulator@105?

Yes.

There are node nvidia,refclk-select-gpios in /proc/device-tree/pcie_ep@141a0000 and regulator@105 in /proc/device-tree/fixed-regulators

I just checked the log. It looks like “Failed to get slot regulators” does not come from the driver. Which means the patch should be applied.

Could you check if the WAR mentioned by this user could work?

Do as link ,still not work, not 12v output