Apt upgrade broke my system

So, I got my first Jetson development board (Jetson Nano 2GB) and used it for a while. All works mostly fine.

I installed a few packages and after running sudo apt update I noticed there were 100+ packages available for upgrade. Ubuntu was also informing me there were many upgradable packages. Thus, I decided to upgrade the system with the “usual” way -
sudo apt update
sudo apt upgrade and answered y to any prompts.

The upgrade process completed without any errors and I rebooted the system. Unfortunately, this time it would not boot past the first Nvidia screen.
So this is the sequence of events that happens leading up to the hang:

  1. Power on
  2. Some init text appears on the screen, and a blinking cursor appears for a while
  3. The Nvidia screen appears (everything up to now appears during a normal boot)
  4. The screen turns black (not normal)
  5. It hangs here forever with the power LED on

No device is recognised on the macOS computer when plugging a Micro USB cable into the socket (I’ve did it before while it still worked and was able to connect to the serial terminal)

This has happened twice after I tried upgrading again on a freshly-flashed system. I’m in the process of flashing again, and will not upgrade it this time until i get some clarification about this matter.

This is my first time posting here, so please inform me if I have forgotten to include some information or posted wrongly. Thanks

This is also reported by other users. We have a workaround here.

Thanks for your prompt response! I’ll take a look at that topic and will post updates of this problem.