Jetson nano 2GB: Black screen after update software and bootloader and then restart

I am using official jetson nano image. After installing updates on jetson nano 2gb. A message appeared that bootloader update needs a restart. And also the same happened after perform “sudo apt-get upgrade”.
I restart the jetson nano then after showing nvidia logo a black screen comes in and I can only access terminal by typing cntr+alt+f1
What should I do?


I have tried doing
sudo dpkg-reconfigure lightdm and then choose “gdm3” as default display
Then reboot
Now I can open os image but the login window is not as previous.

I have this very exact issue - after software update the default nvidia desktop just blackscreens. Please help.

1 Like


Yes, it is a known issue and we are still investigating. Some discussion are on another posts.


Thanks alot for your reply and support.
I have reflash os image and tried your suggestion:
sudo apt update
sudo apt-mark hold systemd
sudo apt upgrade
sudo reboot
And everything goes fine unlike before.
Thanks alot for your help :)