Jetson Nano 2GB how to disable Headless mode on boot/startup

It looks like my Jetson Nano 2GB defaults to Headless/terminal mode on boot/startup and I can’t figure out how to disable it. I’ve tried re-flashing my SD card a few times and I’m able to enter the Ubuntu desktop normally but it reverts to headless mode after a few boot ups. Perhaps it notices that it’s on the same Wifi network as my desktop? I have not connected to it using headless mode on my desktop machine so I’m not sure why it keeps booting with headless mode defaulted.

I’ve tried to switch to the GUI using Ctrl-Alt-F7 or Alt-F7 (result is a black screen), with Ctrl-Alt-F8 or Alt-F8 (result is a black screen with a flashing dash/underscore). Ctrl-Alt-F1 to F6 gives me different TTY terminals.

The only way I can get into the Ubuntu desktop is to go to the terminal with Ctrl-Alt-F1, sign-in, then,

sudo systemctl start gdm3.service

then sign-in again. Once inside Ubuntu, in LXTerminal

sudo systemctl set-default

and then a reboot. I’ve read that this should default to the GUI on boot but it doesn’t in my case. It goes to headless mode again.

Any help? Forgive me if some of my terminology is incorrect as I’m fairly new to Linux and coding.


Mods you can delete or link this issue to the blank screen issue below. I didn’t see this thread until after writing mine.

1 Like