Jetson Nano won't go past startup or open terminal

I am stuck at startup with my Nvidia Jetson nano, running Ubuntu 18.04.

When it boots, it will show the startup-screen (the stream of text), then it stops running and just hangs. No GUI ever shows up. I cannot open the terminal using Ctrl+Alt+F3 (it acts as if I’m just pressing Alt+F3).

This is the text that is displayed on the screen:

tegradc tegradec.1 dpd enable lookup fail:-19
host read timeout at address 545c00c4
imx219 board setup failed
img219_board_setup error during i2c read probe
cgroup2 unknown option “nsdelegate”
random: 7 urandom warnings missed due to ratelimiting
direct firmware load for iwlwifi-8265.26.ucode failed with error -2

I have switched keyboards, unplugged and restarted several times, and tried booting with nothing connected except for power, keyboard, and HDMI.

I have also tried booting into the GRUB menu, but nothing happens when I hold down ‘Shift’ or ‘Esc’.

Any suggestions for something else I can try? I can’t run any scripts or edit anything because I can’t pull up the terminal.

Normally I would ssh into the computer, but I recently tried to update it to use a static IP, and now I cannot figure out the new IP address so I cannot change anything that way.

Jetsons (and most every embedded system) does not have GRUB. A Nano instead has U-Boot, and this is accessible only via serial console during boot. FYI, a serial console boot log would say a lot about what is going on, and this would be the next step in most cases. See:

It would also be necessary to know which model of Nano this is: The dev kit with SD card, or an eMMC module on a third party carrier board. Also, any steps for software install would be needed. Especially in the case of the SD card model, where the QSPI memory (used for boot) on the dev kit must have been flashed correctly to go with the release on the SD card. So every detail you have about flash or update of the system is important to know.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.