No USB on startup

The Jetson Nano pulls up the NVIDIA logo then hangs. Tried both the headless and keyboard methods to pull data from the startup, but neither works. The keyboard and mouse isn’t recognized and the headless USB doesn’t appear. At this point I don’t know if it’s a failed USB interface or a software issue. Is there a way to re-initialize the unit to factory defaults?


can you elaborate more about this?

Have you tried to re-flash the device? Use SDK Manager of flashing scripts provide in our BSP:

Thanks for the advice! Very helpful!

Took me a while to read through it all. Looks like I will need a separate Ubuntu computer? This may take a while…

1 Like

Incidentally, the easiest thing to do is to add another disk and put Ubuntu 18.04 on that. You could also partition the existing disk if you have room, but that requires a lot more care. Both work as dual boot and will save your sanity.

That’s right.
Sometimes issues may not be solved by simply re-flashing SD cards with the image, and you will need to use our SDK Manager, which is only available on Ubuntu, to do a whole re-flash.

Sorry this took a while. Thanks linuxdev, DaveYYY - you got me on the right track!!

I had to get an Ubuntu Mini PC, but it came with ver 20. I had to downgrade it to 18.04 for SDK Manager to work. Once that happened, I had to figure out how to Force Reset the board by holding a wire to the soldering points underneath the board. The full instructions (for anyone who has the same issue) is located here:

Again - thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.