Jetson Nano 2GB First Boot Issue


I’ve got a Jetson Nano 2GB Developing Kit.

When I tried to boot for the first time, I tried both the headless mode and the ‘normal’ mode.

When trying to boot for the first time in the ‘normal’ mode, the card gets stuck in the first screen, shows an NVIDIA logo and nothing else happens.

Then, I tried my chances in the headless mode. Now, I’ve got PuTTY installed on my computer, and I am connecting it via a micro USB cable. However, when I try to look for the COM port from the device manager, for that device it says: “A request for the USB device descriptor failed.” “(Code 42)”. I suspect a driver incompatibility.

Now, to fix this, I have so far:

  • Changed the SD Card
  • Changed the Cable (both micro USB and type-C)
  • Changed the Adapter I’m Using (Currently a 5V 3A iPhone Adapter)
  • Changed the monitor (was trying with my desktop monitor, I tried it with an older HDMI TV this time as I didn’t have the monitor
  • Written the image several times to the SD Card
  • Found out that there are two images, and only one is for the 2GB version, so wrote that image several times as well.

However, nothing seems to work. And unlike cards like Arduino, Raspberry Pi, and such, the resources for the 2GB Jetson Nano online are quite limited, hence this article.

Also, it’s good to mention: when I connect the Jetson to my display before powering it up, it shows me the NVIDIA logo when booted. When I power the Jetson up, and then connect the HDMI display, the display doesn’t get any signal from it.

Could you help me with the issue?

Thank you!

Please prepare another x86 ubuntu 18.04 host. Install sdkmanager and use sdkmnager to flash your jetson.

The reason to use sdkmanager is written in the “Flash problem” in below website.

Thanks for the help!

Is it possible to use a VirtualBox VM for this purpose? I run Windows on my computer and have Ubuntu on VirtualBox.

Sorry, VM/VB may not have stable usb connection so the flash may fail.

Hello, I’m now writing from Ubuntu, which I am dual booting from my laptop now!

Unfortunately, the system fails to identify my Jetson Nano, hence I can’t use NVIDIA SDK, nor the serial terminal to communicate with the card.

Mostly likely you are not putting the board into recovery mode.

Please read the developer guide and put a jumper on the REC pin to make the board in recovery mode.

I’ve tried that just now, although I still cannot see Jetson Nano on my computer. NVIDIA SDK cannot detect it.

I also realized that I was using Ubuntu 22.04, and you wrote 18.04. I’ve tried downgrading, although for some reason it won’t install on my laptop -even after disabling secure boot and so-, hence I tried it out on a VM, although it still won’t see the jetson on the 18.04 VM :/ .

By the way, should the Ubuntu host computer be 32-bit, is that a necessity?

So in short, even when I put a jumper on REC pin with the GND pin:
Ubuntu 22.04 VM AMD64 - No detect
Ubuntu 22.04 Local AMD64- No detect
Ubuntu 18.04 VM AMD64 - No detect
Ubuntu 18.04 Local AMD64/32-Bit - Won’t install/No ISO available.

Could you share a screenshot from sdkmanager for this case? This should work there. Not sure why there is won’t install info.

And one reminder here. You also need to power on the board after you jumper the REC + GND pin on the board.

Check the lsusb on your host after you connect the micro usb cable.

If lsusb does not show NVIDIA device, please check what is the kernel log shown after you connect the micro usb. Use command “dmesg” on your host terminal and it will show.

Ah, I believe there’s a misunderstanding. That was not the error log of the SDK Manager, I meant that the Ubuntu 18.04 installer won’t boot on my device, and I couldn’t find an ISO for the 32-bit version of Ubuntu 18.04, the only one I found said 18.04.06, AMD64. Is that compatible?

Oh. Sorry.

Yes, it has to be amd64.

Yes, I’ve checked that using the command:
“$ dmesg | grep --color ‘tty’”.
Although I only saw my SD Card there that way, there was no difference before and after.

Okay, thanks! I’ll try booting my system again with the amd64 image. I believe it’s a secure boot caused issue, but I’ll see.


This is not tty device. It is just a pure usb device.
I don’t think you need to grep anything in dmesg.

Very well, I’ll try again.

If you don’t see it in your lsusb or dmseg, then it means

  1. Nano 2gb is not in recovery mode

  2. VM cannot detect your jetson nano

  3. The micro usb has problem (most cases are using charging line which don’t have data line on it)

By putting it in recovery mode, you mean shorting the REC and GND pins, and powering up the device, right?

I won’t use the VM to avoid #2

I’ve tried it with 4 microUSB cables so far, which I’ve previously connected devices to my laptop with and transferred data, so I’d say the odds are low on that :)

Yes, also checking the dmesg as my previous comment says to see whether the usb detection is fine.

1 Like

Writing from local Ubuntu 18.04 here!

Here are the screenshots I get, I removed a flash drive and replaced it with my microUSB cable, it doesn’t show anything.


The first part belongs to the dmesg command, while the second part is for lsusb.

SDK cannot detect the card either…

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.


Please take a photo of how your connection and how your jumper is connected.

Also, are you sure jetson nano has power LED light up?