Jetson 2GB white screen with logo

Good afternoon,

Recently I bought Jetson 2GB. When I tried to proceed with the steps in the Getting Starting (Getting Started with Jetson Nano 2GB Developer Kit | NVIDIA Developer) I faced the booting problem when I saw just the white logo. I used different images from 4.4 to the latest, I used different power supplies with the required output. Also, different microSD cards with different storage capacities. I tried different jetsons (bought many of them) in standalone mode, with windows and macOS devices. Always has the same result. Also, I tried to use a USB to COM port (RXD-green, TXD-white, and ground cables), and I cannot detect the device in Win 11.

What did I do wrong, and what should I do? I didn’t find the proper solution in the forum.

Hi dmitrii.etingov

Are you using Jetson Nano devkit?
Have you tried to install jetson with SDK Manager?
Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation
It’s recommended using Ubuntu as host PC OS for development.

There’s a similar thread as yours, please also refer to it if that could be any help.
Jetson nano 2gb “white screen w/ NVDA logo” at boot up

Hi Kevin,

Thanks for your response and help.
I use Jetson Nano and I tried to use SDK Manager. But for the virtual machine only. As I got it, would it be not possible to set it up without the real ubuntu machine?

Another point is why on the main page it is written that it would be easy to use Nano 2GB from the MSFT Windows. And nothing about these problems if not read forums. We bought 20 pieces for the university, and cannot use them at all. Could someone do something about it? All Nanos (4gb for example) have the same problem?

VMs have been known to work, but the end user will have to figure out how to correctly set up USB (typically a VM won’t pick it up correctly when the USB disconnects/reconnects during the flash). VMs are not officially supported, it would be up to the VM owner since the VMs differ. In the end though, you would be far less frustrated with an actual Ubuntu 18.04 machine (perhaps dual boot, but make sure it has enough disk available). The Windows WSL tends to not work since it does not support loopback (I was told it is possible to add that, but I think it was a lot of trouble, and failure is guaranteed without that).

It is easy to talk to a Jetson over serial console or ssh from most any host (including Windows or MAC). In Linux though this is trivial.

1 Like

Hi Kevin,

I tried the ubuntu (18.04) host machine with the last SDK Manager, and I found out that the system didn’t see any of our Jetson Nano 2GBs (via terminal). I tried to make it work through the manual flashing but was not able to flash it.

What can I do in this case?

Hi dmitrii.etingov,

What’s the purpose of your usage?
Just like @linuxdev said, you can interact with Jetson through ssh from different host OS and develop in it. There’s an Ubuntu OS running in Jetson. If you want to modify something in kernel, rootfs or even develop a custom board, I recommend developing with Linux based host PC because SDKM and several flash commands are only available through terminal.

Do you connect your devkit to host PC by type-C port?

  • type-C: for flash
  • Mirco-USB: for UART console

You can use lsusb commnad in terminal to check if there’s any device named NVidia Corp..

Once again, I already tried lsusb command. I don’t see anything with NVidia Corp in my device list. Neither before nor after connecting two systems. For power, I used the TypeC, for flash NANO 2GB has only microusb. Of course, I tried to use different cables. Also, I used tips with flashing via the recovery mode (REC and GND pins) and SDK Manager in Ubuntu host machine (18.04) - doesn’t work.

Purpose - the next research. They were bought from the official distributor in NY state (U.S.).

What else can I check?

What is your method to put the board into recovery mode? Could you show us?

Or do you have other jetson nano device to check if your host can detect other jetson or not?
This could clarify whether it is host side issue or device side issue.

Cannot detect board in recovery mode is a pure hardware problem. It could be either host, micro usb cable or device side.
For micro usb cable, a most common case is users tend to use cable which only has power line but no data line.
For host, most common case is VM setup which cannot detect.

In addition to what @WayneWWW just mentions, it is USB which VMs usually fail on. The Nano could be providing USB in recovery mode just fine. If a VM fails to see this Jetson, then likely it is the VM not having recovery mode Jetsons being passed through the USB; even if it does pass through, any momentary disconnect (which happens automatically during flash) tends to lose the USB and not reacquire USB. Check the VM.

The manual method that was written in SDK references: Install Jetson Software with SDK Manager :: NVIDIA SDK Manager Documentation. Used as it is written in the SDK app specifically for Jetson Nano 2GB. The pins are connected according to Jetson Nano 2GB Developer Kit User Guide | NVIDIA Developer (fig - Top view).

Again: I tried different usb cables that can transfer data. :) As well as the different boards.
Also, as I said, we already are using the real host machine with ubuntu. We cannot detect the boards as connected devices via lsusb command.

Could I request the meeting with your Nvidia Support to better understand what can I do/what did I wrong/etc, please? :)

Thanks for your response, but it’s not the VM. :(
I saw this problem here, and some guys already found a solution that may work. However, building the real host machine with ubuntu (18.04) onboard is easier for me. :)

A real host is also nicer to work on (it is what I would personally pick too).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.