Jetson Nano B01 - problem with first start

Hello,

I have worked with older Nano, I don’t remember having boot problems, but now I bought a new Nano B01, it went dead after connecting HDMI cable to the monitor, here is my quite strange experience (on Win 10):

  1. I downloaded the latest 6GB image - jetson-nano-jp451-sd-card-image.zip
  2. I flashed it on 32GB SHDC SD card
  3. I connected J48 jumper and external 10Ah battery, green led is on
  4. connect with micro-USB to the laptop
  5. I was able to see Jetson Nano on СОМ9 (HardwareIds: VID 0955 and PID 7020)
    6, I was able to connect with Putty (0.74 32-bit), first time there was error message - something like “System can not configure need to boot…” but the second time after I rebooted from battery I was able to configure language, user / password, etc.
  6. then at last I saw these two -
  • APP Partition Size?
  • Delete un-used bootloader partitions ?

After I pressed enter there passed several minutes, then again the message - “System can not configure need to boot…” , I rebooted, connected HDMI cable, keyboard, mouse but there were no signal.

What is worse I do not see anymore Nano in Ports (COM & LPT).

I follow directly :
Initial Setup Headless Mode

Now I can not connect with HDMI, tried several times with another SD Card and battery and another PC, the greed LED on Nano is On but nothing in COM Ports List.I tried without the J48 but can not see anything on the external monitor.

Is this a sign of a physical damage? I have only few days to return it back so please let me know .
Thanks.

No Pro here but it was my experience also that i could not boot successfully from a flashed micro SD. The SDK from an Ubuntu installation worked like a charm. I still see errors pop up “I2c dangling mount and some other stuff” during boot and often have no mouse and keyboard until I unplug and plug them back in.

Installing from docker also failed continually.

Good Luck

Please try with sdkmanager first.

Besides sdkmanager,

  1. We have few users say the image from “Getting Started With Jetson Nano Developer Kit” has some problem. But it can work if they use the image from dlc instead.
  1. What is the boot log from uart?

Hello, fellows.

Thanks, after two full days thankfully I was able finally to install the Nano OK using the Sdkmanager version 4.4.1 from Vbox,Thanks Nvidia that install is now even more buggy.

I was not able to install Nano B01 with the SD Card images, including the above suggested. Please verify that card images works.

  1. We have verified the sdcard image on our side but there is no problem here.

  2. What kind of “buggy” do you see now? Actually, sdkmanager does not support on VM/VB, so I am not sure if anything goes wrong with this setup.

Wasted a morning trying to get the Nano 2G past the NVidia logo with the image from the getting started link…
The jetson-nano-2gb-jp451-sd-card-image from the download center worked!
Thank you,

Hello.
Where did you download it from? For me the Nano 4GB sdcard images (4.5.1, 4.5, 4.4.1) from - developer.nvidia.com/embedded/downloads never worked with B01, I didn’t even reach the NVidia logo, as suggested I installed JetPack 4.4.1 OS with the sdkmanager. But with JetPack 4.5.1 and sdkmanager I have a USB reconnect problem when B01 is in RCM, install is failing after sometimes stuck for many hours, I changed the install script to wait for the device to reconnect (I am using VBox with Ubuntu 18.04 VM). Error was something like:

[ 0.3029 ] tegradevflash --oem platformdetails storage storage_info.bin
[ 0.3036 ] Cboot is not running on device.
[ 0.3353 ]

With only a small fix in the install script however it is possible to flash the OS sucessfully .

I have confirmed there is no such thing like the image from “getting started …” page would not work while the image from download center page will.
These 2 files are actually using the same download link… and we don’t change it.

As for your issue, I can only tell you please do no use VM to flash the board. Sdkmanager does not support VM environment .