Jetson nano 4gb can't find keyboard and mouse

I get only to Ubuntu window with Nvidia End User License agreement. Neither keyboard nor Mouse works. I have tried and tried with different usb ports. still the same. It happened after last clean install with the newest -jp46-sd-card image install.Please help me.

How about some older jetpack release like jp4.5? Will it bring your usb alive?

HELLO! Did it same result. why there is not a clean way to reset to factory default? Many chips have a button or combi function with pins to do this(like (opi3).The help referes to docs with so many other devices that at end one gets even more frustrated . SDKManager wich doesn’t work with some ubuntu versions. i have been trying this in 3 days and night,still the same. No mouse no keyboard and no new install.
I wish there were clear instructs to make more people buy Nvidia, not get afraid of systemupgrade complexity where an upgrade make hole system stop. Kindly regads Vahid


There are some points to clairfy

  1. This issue is possible to be a hardware issue. Which means “recovery mode” may not fix this either.

  2. The “recovery mode” on jetson is just making the board into a state that sdkmanager can flash the board. Which means you still need sdkmanager if you want to do software reset. Please prepare a host that can support sdkmanager first.

  3. The flash process requires the board to be in recovery mode and connect the micro usb on the jetson devkit wit the host side, the method to put the board into recovery mode is as follow:

    For the Jetson Nano Developer Kit, follow these instructions:

1. Ensure that your Jetson Nano Developer Kit is powered off, and that a 16GB or larger
           microSD card is inserted into the SD card slot.
	2. Enable Force Recovery mode by placing a jumper across the FRC pins of the
           Button Header on the carrier board.
	3. For carrier board revision A02, these are pins 3 and4 of Button Header (J40) which
           are located near the camera header.
	4. For carrier board revision B01, these are pins 9 and 10 of Button Header (J50), which
           is located on the edge of the PCB under the CPU module
	5. Place a jumper across J48 to enable use of a DC power adapter.
	6. Connect a DC power adapter to J25. The developer kit powers on automatically and
           enters Force Recovery mode.
	7. Remove the jumper from the FRC pins of the Button Header.
	8. Continue the software installation.

Hello! thanks for koke book. I tried it with SDGmanager on ubuntu 20.04 no luck. I read that one should use ubuntu 18 or 16 because SDK manager has some problems in ubuntun 20. I will it a last try tomorrow if it no luck, i will it to a maker group her in Trondheim to use and then i buy a new one. Thanks for your kindness. it is 04 in the morning here in Norway and i need to sleep after 3 days and nights. vahid

Please be careful that sdkmanager runs on x86_64 hosts. Which means you cannot use another jetson nano, which is arm64 arch to be as a host.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.