It seems that is my jetson nano has hardware failure

It seems that is my jetson nano has hardware failure. I can’t neither login or through ssh. What do i do? It seems that carrier board is defect. I don’t another one to test. Here is modelnr and serialnr. where do i send it to at least buy or get a new one.
Model: P3450
Kindly regards

We didn’t hear from you for 2 months. Have you reflashed the board with sdkmanager?

I was ill for almost two months(Covid 19). I have tried every possible step quite a few times. .I have tried with ubuntu 20.04 SDKmanager doesn’t find the nano. Many times with other pc’s with no luck.
I tried with new SD cards(at least 3 different SD cards) nothing after the Nvidia accept page happens since no mouse or keyboard works (No response from Jetson).
My son in law is an electronics engineer. He tested the usb ports with no signal. He told me it must be a hardware problem.
All I ask is to get the chance to buy a new one. No stock in the market. I have checked almost 30 web shops with no luck.

I bought mine directly from the Nvidia web shop. I hope you can help me.
Kindly regards
Vahid Sabalani


  1. The sdkmanager for jetson needs to be a 18.04 host.

  2. If the usb port has no signal, then the hub might be broken. If you want to RMA this module, please file RMA request with

I will set up a pc with ubuntu 18.04 to test it after work. Thank you for the information.

Kindly regards
Vahid Sabalani

1 Like

If still cannot work after full re-flash,then please file RMA request.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.