Argus_camera error

how to use argus_camera? I run argus_camera, it report errors as belows./dev/video1 and /dev/video2 is ok.I have used v4l2_ctl to capture data.

please check Verifying the V4L2 Sensor Driver to examine your basic camera functionality.

I can get data by v4l2-ctl, and it is bayer raw sensor.

hello jasonGrave,

may I also confirm which Jetpack release version you’re working with.
please check $ cat /etc/nv_tegra_release for confirmation.

could you please also gather kernel logs for checking, $ dmesg > klogs.txt
it looks your camera streaming via v4l did not stable in the beginning.

the release version is
“# R35 (release), REVISION: 1.0, GCID: 31346300, BOARD: t186ref, EABI: aarch64, DATE: Thu Aug 25 18:41:45 UTC 2022”.I restart nvargus-daemon and get some logs. v4l2 is not stable in the begining seconds, after some senconds it is stable.

mydts.txt (288.4 KB)
nvargus-daemon.txt (67.8 KB)
klogs.txt (79.3 KB)

hello jasonGrave,

it looks you’re working with serializer/deserializer chip.
it should be unstable to crash Argus pipeline.
please give it a try to enable Infinite Timeout Support.

r35.1 is an quite old release version, we’ve recently public release JetPack 5.1.3 (i.e. r35.5.0) which include several camera bug fixes.
is it possible for moving to the latest release for verification?

it seems the same error. At this stage won’t upgrade the release version.

the program nvargus_nvraw show nothing

the failure it’s due to Argus side cannot initialize camera.
could you please give it a try to update position property within tegra-camera-platform {} as rear and front for dual camera use-case.

the devname should change to zedx 0-0010/ zedx 0-0018? it print zedx 0-0010 bound in the dmesg

I have changed the position and devname,it also report errors.

hello jasonGrave,

it’s bad practice for sharing error messages with screenshot.
for better reading, please gather the logs and uploading the file as attachment, or, you may pasting them with code block command, (i.e. <code>LOGs</code>) into forum discussion thread.

BTW, is it possible for moving to the later L4T release version for confirmation.

newdts.txt (288.4 KB)
nvargus-daemon_3_15.txt (86.7 KB)
klog_3_15.txt (83.7 KB)
I have changed the dts, here are the logs

hello jasonGrave,

it still report errors of sensor initialize.

NvPclDriverInitializeData: Unable to initialize driver v4l2_sensor
NvPclInitializeDrivers: error: Failed to init camera sub module v4l2_sensor
NvPclStartPlatformDrivers: Failed to start module drivers

please also review serdes_pix_clk_hz property settings by referring to SerDes Pixel Clock.

please also give it a try with below commands to boost all the VI/CSI/ISP clocks.
for instance,

sudo su
echo 1 > /sys/kernel/debug/bpmp/debug/clk/vi/mrq_rate_locked
echo 1 > /sys/kernel/debug/bpmp/debug/clk/isp/mrq_rate_locked
echo 1 > /sys/kernel/debug/bpmp/debug/clk/nvcsi/mrq_rate_locked
echo 1 > /sys/kernel/debug/bpmp/debug/clk/emc/mrq_rate_locked
cat /sys/kernel/debug/bpmp/debug/clk/vi/max_rate |tee /sys/kernel/debug/bpmp/debug/clk/vi/rate
cat /sys/kernel/debug/bpmp/debug/clk/isp/max_rate | tee /sys/kernel/debug/bpmp/debug/clk/isp/rate
cat /sys/kernel/debug/bpmp/debug/clk/nvcsi/max_rate | tee /sys/kernel/debug/bpmp/debug/clk/nvcsi/rate
cat /sys/kernel/debug/bpmp/debug/clk/emc/max_rate | tee /sys/kernel/debug/bpmp/debug/clk/emc/rate

I have tried this,but it doesn’t work.It hasn’t call the any zedx driver(the camera driver) interface,it seems that it doesn’t match somewher.I see others’ same faq it says that tegra-camera-platform is configured wrong,but I dont know where is configured wrong.Now that I can get the data by v4l2-ctl, why does argus_camera still report that there is no recognized device?

hello jasonGrave,

because those plugins were went through different pipelines.
please refer to NVIDIA camera software architecture as see-also.

it’s a big concern that sensor took several seconds to stable.
if that’s possible, please moving forward to r35.5.0 for verification, there’re code check-in to fix set_mode_delay_ms functionality.

it is stable now,but argus_camera reports the same errors.How to analyze this problem? Is there any debugging method to find the problem?

hello jasonGrave,

may I also know what you’ve done? for instance, had you revise driver settings to made some progress of sensor streaming in v4l2?

96712 mipi should disable first, and when start stream enable mipi.

The problem with argus_camera should not be a data flow issue, as it has not yet called any driver setting interface, so how can it be a data flow issue?