Artifacts (vertical lines) in QHD resolution over DisplayPort connection

Hello.

I have an issue with artifacts (faint vertical lines) appearing in QHD (2560x1440) resolution when monitor is connected over DisplayPort.

Configuration: Manjaro KDE (Kernel 5.4) / Dell P2418D (DP v1.2) / Palit GTX1660 Super.

Those are mostly visible on gray-scale/darker backgrounds, e.g.


The horizontal scanlines became partially visible as well (I have sensitive eyes).

Steps I’ve taken trying to narrow down the problem:

  1. Tried another DP cable - issue persists.
  2. Tried with another distro (Ubuntu19.04 in live mode with driver installed (albeit version 418)) - issue persists:
    https://ibb.co/x66rSfc
  3. Running without nvidia driver (just nouveau) - no visible artifacts.
  4. Lowering the resolution to 1920x1080 - no artifacts (at least there are no vertical lines but some slight pixel inconsistency instead, sort of ‘X’ grid).
  5. Switching to HDMI connection - no visible artifacts.
  6. Using DP-to-HDMI cable - no visible artifacts.
  7. Finally I installed Windows10 with 441.08/441.41 driver and used the same DisplayPort connection - no visible artifacts in QHD.

Additional information:

  1. I tried to play with xrandr setting custom resolution of 2560x1440_59Hz, and this seem to affect lines visibility somehow, but not completely eliminated them.
  2. Those lines may appear in different places, i.e. on different dark backgrounds. I can spot them in one part of the Telegram UI, turn the monitor off and on, and then they appear in other places of the UI.

Thank you in advance.
nvidia-bug-report.log.gz (208 KB)

I decided to test the GPU in Windows.

First I ran AIDA64 GPU test - it completed successfully.

In order to stress test the GPU I ran Furmark with different presets couple of times.
Result: no visible artifacts (Windows + 441.41 + DisplayPort + QHD resolution), stable run, no overheating.

Can you please suggest trying anything else?
Could this be a Linux driver bug?

I thought about returning this card to store’s service center for extended diagnostics, but I think they will simply plug the GPU into Windows PC and find no problems with it.

Thanks.

I’ve been having the same problem since I switched from HDMI-to-DVI to DisplayPort. The problem happened on my GTX 1060 and still happens on my new RTX 2080.

Also noticed that on a screenshot, viewed from another device, the artifacts don’t show.

I would guess it’s either something in the driver when displaying over displayport, or the cable itself. I don’t have another cable to test though.

Please check if this is some problem with dithering by disabling it, setting

Option "FlatPanelProperties" "Dithering = disabled"

in the device section of your xorg.conf. You can also check a different DitheringMode:
https://download.nvidia.com/XFree86/Linux-x86_64/384.98/README/xconfigoptions.html
AFAIK, Windows doesn’t support dithering on GTX/RTX type cards.

@generix

Looks like this did the trick! Thank you very much!
I will double-check tomorrow that my eyes are not lying, but the change is obvious.

Here’s how my xorg.conf (nvidia.conf for Manjaro) ‘Device’ section looks like:

<b>Section "Device"</b>
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
	Option "FlatPanelProperties" "Dithering = disabled"
<b>EndSection</b>

So, what does this mean, what is causing the issue? Is it a driver bug?

Wow, that fixed it for me too! Makes a huge difference.

I tried keeping the dithering on though, but I changed the mode and it looks fine like this.

Section "Device"
    Identifier     "device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "NoLogo" "1"
    Option         "FlatPanelProperties" "Dithering = Enabled, DitheringMode = Static-2x2"
EndSection