Audio2Face in Unreal Engine Packaged Application?

Hey guys, I have the A2F live link set up inside Unreal Engine however whenever I try to package the project inside Unreal with the A2F plugin enabled errors show up and it doesn’t work with an unknown error.

As soon as I disable the A2F plugin it packages perfectly fine.

I have tried this on multiple PCs with different graphics cards and multiple versions of Unreal etc, and at a lose end now as there is no information anywhere on the error.

The workflow to setup A2F livelink inside UE is a little different when you need to package the game. Could you please take a look at this doc and see if it helps?

Audio2Face to UE Live Link Plugin — Omniverse Audio2Face latest documentation (nvidia.com)

Hi Ehsan, thanks so much for getting back to me!

Yes, that is how I have it all set up in a project in 5.3, the same problem happens when I have the A2F plugin enabled in Unreal when trying to package the application, showing an unknown error and it builds completely fine with it disabled.

It looks as if ‘OmniverseAudioMixer’ is the problem with the build.

Could you please share your full log for furthur investigation?

Sure thing, although I have tried this on multiple PCs so I’m presuming this is just an issue not specific to me, do you not get the same error when packaging an Unreal project with A2F plugin enabled?
PackageProjectOutputLog.txt (227.6 KB)

Hey dan214, usually packaging errors might be caused due to a lot of issues. Perhaps one thing to try is to install the following .NET Framework SDKs and targeting packs in Visual Studio (.NET versions : 4.7.1, 4.7.2 and 4.8.1). If this doesn’t solve your issue then we will require a deeper look into your project settings. Thanks.

Hey dmohsin thanks for getting back to me, I have installed the frameworks and still the same errors. I have attached the build log.

I have tried this on 3 separate computers and got the same error, is it a problem on my end or are we not able to package a project in Unreal with A2F enabled? Does it work on your side?

PackageProjectOutputlogNew.txt (227.4 KB)

We have no issue packaging any project in UE with A2F plugin. That’s why we will have to try different things to get an idea why you are facing this issue. While I dig deeper into your issue and try to recreate it, can you specify the location where you copied the A2F plugin?

Ah interesting that is strange, I copied the plugin folder from the file explorer audio2faceplugins in to the engine plugins directory like this video (ss attached) → https://www.youtube.com/watch?v=HEFIvFnUfpw please let me know if you need anything else sending over

Lets try this, create a Marketplace folder within the plugins folder and put the ACE plugin there. Additionally you can create a Nvidia folder within the Marketplace folder and put ACE plugin there. So you can try the following root locations for your ACE plugin folder

  1. UE_5.3/Engine/Plugins/Marketplace
  2. UE_5.3/Engine/Plugins/Marketplace/Nvidia

Let me know if this resolves the issue.

2 Likes

That fixed it!!! Thank you so so much dmohsin.

@dmohsin to circle back to this solution out of curiosity, from the look of OP’s post, the issue would fix itself if the ACE folder was moved elsewhere, is that correct? and while you mentioned creating a Marketplace folder, does the name matter in this scenario?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.