BASICS: Laptop with GeForce G105M only boots to linux mint 19.3 in recovery mode

,

One of our elderly laptops ha a Geforce G105M installed.

  1. Standard boot from USB-Stick to try to install linux mint tricia 19.3 on hard disk (HD) ended up in a blank screen.

  2. Booting of linux mint tricia 19.3 from USB-Stick was only possible in “Compatibility Mode”.

  3. After the installation to the HD, the boot from HD also ended up in a blank screen.

  4. Anyhow via booting into “recovery mode” we managed to get the system run with a driver that seems to be “xserver-xorg-video-nouveau”.
    The command ubuntu-drivers devices gives the following output:

    == /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
    modalias : pci:v000010DEd000006ECsv00001558sd00000802bc03sc00i00
    vendor   : NVIDIA Corporation
    model    : G98M [GeForce G 105M]
    driver   : nvidia-340 - distro non-free recommended
    driver   : xserver-xorg-video-nouveau - distro free builtin
  1. Did a timeshift (rsync) backup

  2. Tried to install the recommended nvidia driver via the command…

        $ sudo ubuntu-drivers autoinstall

… which reported no errors, but ended up in a blank screen boot also.

  1. Created the attached file local_nvidia-bug-report.log.old.gz (Please remove the last “.log” from the filename after downloading it)

  2. Restored the runnning sysrem via timeshift --restore

  3. In the running system the Monitor is recognized as "unknown with no possibility to add another monitor or change resolution, etc.

The file local_nvidia-bug-report.log.old.gz is full of error messages like

NVRM: RmInitAdapter failed! (0x12:0x2b:1915)
NVRM: rm_init_adapter failed for device bearing minor number 0
NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5

We would like to add another monitor to the system, which seems to be only possible if the correct nvidia 340 driver s successfully loaded.

If anyone would have any tips how to proceed from the actual state, that would be great.

Thanks in advance,
richard

local_nvidia-bug-report.log.old.gz.log (56.3 KB)

If the nouveau driver is loaded you need to blacklist the module.

Points to hardware failure. But you got a lot of messages about the card spanning over more then one PCI bar.
Is you bios up to date? Do you have a bios option to enable “Above 4G decoding”?

Thank you very much for your reply.

Yes, the BIOS is the most up to date version (the Laptop is more than 10 years old).

No, there is no option like enabling “Above 4G decoding”.
The laptop has 3G installed.

Could the spanning over more than one PCI bars come from the second monitor which is attached to the VGA-port, but is not recognized with the nouvou driver?

Question:
When shall i blacklist the nouveau driver?
Before or after the installation of the nvidia-340 driver via ubuntu-drivers autoupdate ?

Thank you very much.

I guess you confuse that with mobile networking.

I don’t think so.

After. Also the nomodeset parameter should be removed if present.

According to this:


You could try the 390 legacy driver…
Use this ppa: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

Did that system work before with windows?

Yes, it is still Dual-Boot, but Windows will be removed as soon as both monitors can be used under linux, too.

Forgot you need to use nvidia-prime if your system has an integrated gpu.

I thought, you spoke about Memory?
The laptop has 3GB installed.

But an option “Above 4G decoding” is not to find in the BIOS.

That option is for large PCI addressing.

OK, I’ve read something about it and will check it out soon.

So, first nvidia-prime install, then the nvidia-340 installation?

Thank you

after driver installation use: prime-select nvidia
I’d rather use the 390 legacy driver I told you about.

I found the following page:
https://www.nvidia.com/en-us/drivers/unix/legacy-gpu/

And there the “GeForce G 105M” is NOT listed under title The 390.xx driver supports the following set of GPUs., but more down the list under the title The 340.xx driver supports the following set of GPUs..

Would you nevertheless recommend to try using the 390 driver?

Thank you very much for your attention and your care.

I trust your research… maybe I didn’t look carefully enough.

Support for Fermi-based GPUs
Fermi-based GPUs are no longer supported starting with release 396. These GPUs will continue to be supported through the release 390 legacy branch, which will receive critical bug fixes and updates for compatibility with new Linux kernels and X server versions through the end of 2022.

https://www.nvidia.com/en-us/drivers/unix/legacy-gpu/

that’s where I looked…

Actually we looked on the same page.

And i could lookup the “GeForce G 105M” with the Device PCI ID in the uploaded bug-report.log file, which found the PCI ID 0x06EC

Line 197 says:

[  1197.827] (--) PCI:*(1@0:0:0) 10de:06ec:1558:0802 rev 161, Mem @ 0xd2000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00009000/128, BIOS @ 0x????????/131072

Line 610 says:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G98M [GeForce G 105M] [10de:06ec] (rev a1)

And the last time it is mentioned at line 2760:

[    0.357569] pci 0000:01:00.0: [10de:06ec] type 00 class 0x030000

And because the PCI ID 0x06ec can only be found once, indicating the GeForce G 105M on the “legacy-gpu” page under the section The 340.xx driver supports the following set of GPUs., i would prefer to use the 340 driver, not testing with the 390 driver.

Would you agree or would you think it would be worth trying?

Thank you very much, you are great help.

I agree

1 Like