Mint 19 crashes with NVIDIA drivers 390 or 340 and GeForce GT630

Driver 390.46 and 340 are installable but after reboot system doesn’t restart.
Need OpenGL 4.5 otherwise nouveau works perfectly!

Please advise!

How did you install the driver?
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

I installed the driver regularly using the MINT 19 Driver function, prompting for reboot after complete install. After Reboot the screen hangs with a blinking cursor, I cannot start the terminal with CRTL+ALT+F1.
Where can I find “nvidia-bug-report.sh”?

nvidia-bug-report.sh get installed along with the driver.
If you can’t switch to VT, try to ssh in from another system. Install openssh-server to be able to do so.

Managed to create the bug report, pls find attached
nvidia-bug-report.log.gz (73.3 KB)

Doesn’t look good

[    5.181720] NVRM: failed to copy vbios to system memory.
[    5.181881] NVRM: RmInitAdapter failed! (0x30:0xffff:663)
[    5.181906] NVRM: rm_init_adapter failed for device bearing minor number 0

Can have various causes. Defective hardware, kernel incompatibility, pcie slot problems.
Try reseating the card, change slot if possible, upgrade/downgrade kernel, check if card works in a different system.

Might also be a corrupt vbios. To check for that, switch to nouveau and add the following to kernel commandline

nouveau.debug=debug,VBIOS=trace

Reboot, run dmesg > dmesg.txt and attach.

Where exactly and how do I add “nouveau.debug=debug,VBIOS=trace”?

https://askubuntu.com/questions/19486/how-do-i-add-a-kernel-boot-parameter

Here it is …
dmesg.txt (62.6 KB)

That didn’t work, the command line is still:

Command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-24-generic root=UUID=cd47eae9-6000-4c4d-ab12-8369c2175651 ro quiet splash vt.handoff=1

If you changed it in grub config, did you forget to run sudo update-grub afterwards?
you can check the current cmdline with
cat /proc/cmdline

Sorry, here it ist
dmesg.txt (250 KB)

Unfortunately, this time the xorg nouveau usage overflooded the dmesg. Please disable the xserver using
sudo systemctl disable display-manager
and reboot, then run dmesg > dmesg.txt again and attach.
Afterwards, you can reenable and start xorg using
sudo systemctl enable display-manager
sudo systemctl start display-manager

Unfortunately enabling doesn’t work … =8-o
It says failed to enable unit: unit file display-manager does not exist.

Here it is
dmesg.txt (144 KB)

use
sudo systemctl enable lightdm
or
sudo dpkg-reconfigure lightdm
to get the login back.

Thanx - went the timeshift way … ;-) But now I know for next time … :-)

Nouveau reports a checksum failure

[    1.130414] nouveau 0000:01:00.0: bios: 00000000: type 00, 62464 bytes
[    1.168264] nouveau 0000:01:00.0: bios: 00000000: checksum failed

The proprietary driver doesn’t accept that, so fails. It’s a very rare condition, you can either try to use nvflash to reflash a sane image or, if reflashing doesn’t work, use the method from this thread:
https://devtalk.nvidia.com/default/topic/1020418/linux/lenovo-y550-gt-m240-vs-ubuntu-17-07-16-04-14-04/post/5196169/#5196169
Or simply replace the card.

OK, thats bad news. How do I use nvflash?

And where do I get a sane image …?